aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/linux.scm7
1 files changed, 3 insertions, 4 deletions
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index b5201a3b74..82e4552194 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -3133,10 +3133,9 @@ write access to exFAT devices.")
;; need to bootstrap things ourselves.
(substitute* "autogen.sh"
(("/bin/sh") (which "sh")))
- (and (zero? (system* "./autogen.sh"))
- (begin
- (patch-makefile-SHELL "Makefile.include.in")
- #t)))))
+ (invoke "./autogen.sh")
+ (patch-makefile-SHELL "Makefile.include.in")
+ #t)))
;; Make sure programs find libgpm.so.
#:configure-flags (list (string-append "LDFLAGS=-Wl,-rpath="