summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/haskell-web.scm30
1 files changed, 30 insertions, 0 deletions
diff --git a/gnu/packages/haskell-web.scm b/gnu/packages/haskell-web.scm
index 874400890b..e5ec572e1d 100644
--- a/gnu/packages/haskell-web.scm
+++ b/gnu/packages/haskell-web.scm
@@ -1628,3 +1628,33 @@ cookies, serving files, and more.")
that is intended to have lightweight dependencies and to be free of all
non-Haskell dependencies.")
(license license:asl2.0)))
+
+(define-public ghc-scalpel
+ (package
+ (name "ghc-scalpel")
+ (version "0.6.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append
+ "https://hackage.haskell.org/package/scalpel/"
+ "scalpel-" version ".tar.gz"))
+ (sha256
+ (base32
+ "0jbrfcgljl8kbcwi2zqx1jp3c3dpxrkc94za44x56kcz68n89hlz"))))
+ (build-system haskell-build-system)
+ (inputs
+ `(("ghc-scalpel-core" ,ghc-scalpel-core)
+ ("ghc-case-insensitive" ,ghc-case-insensitive)
+ ("ghc-data-default" ,ghc-data-default)
+ ("ghc-http-client" ,ghc-http-client)
+ ("ghc-http-client-tls" ,ghc-http-client-tls)
+ ("ghc-tagsoup" ,ghc-tagsoup)))
+ (home-page "https://github.com/fimad/scalpel")
+ (synopsis
+ "High level web scraping library for Haskell")
+ (description
+ "Scalpel is a web scraping library inspired by libraries like Parsec
+and Perl's @code{Web::Scraper} Scalpel builds on top of TagSoup to provide a
+declarative and monadic interface.")
+ (license license:asl2.0)))