summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/plotutils.scm14
1 files changed, 13 insertions, 1 deletions
diff --git a/gnu/packages/plotutils.scm b/gnu/packages/plotutils.scm
index 237baa932c..ac8a6f46fc 100644
--- a/gnu/packages/plotutils.scm
+++ b/gnu/packages/plotutils.scm
@@ -1,5 +1,5 @@
;;; GNU Guix --- Functional package management for GNU
-;;; Copyright © 2013, 2014, 2015, 2016, 2017, 2018, 2019 Ludovic Courtès <ludo@gnu.org>
+;;; Copyright © 2013, 2014, 2015, 2016, 2017, 2018, 2019, 2020 Ludovic Courtès <ludo@gnu.org>
;;; Copyright © 2015 Eric Bavier <bavier@member.fsf.org>
;;; Copyright © 2016, 2017, 2019, 2020 Nicolas Goaziou <mail@nicolasgoaziou.fr>
;;; Copyright © 2018 Tobias Geerinckx-Rice <me@tobias.gr>
@@ -99,6 +99,11 @@ scientific data.")
(modules '((guix build utils)))
(snippet
'(begin
+ ;; Allow builds with Guile 3.0.
+ (substitute* "configure"
+ (("2\\.2 2\\.0")
+ "3.0 2.2 2.0"))
+
;; By default, .go files would be installed to
;; $libdir/…/ccache instead of $libdir/…/site-ccache. Fix
;; that.
@@ -116,6 +121,13 @@ scientific data.")
using the Cairo drawing library.")
(license license:lgpl2.1+)))
+(define-public guile3.0-charting
+ (package
+ (inherit guile-charting)
+ (name "guile3.0-charting")
+ (inputs `(("guile" ,guile-3.0)))
+ (propagated-inputs `(("guile-cairo" ,guile3.0-cairo)))))
+
(define-public ploticus
(package
(name "ploticus")