summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/crates-io.scm3
-rw-r--r--gnu/packages/rust-apps.scm4
-rw-r--r--guix/build/cargo-build-system.scm2
3 files changed, 3 insertions, 6 deletions
diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index 1099a25d87..a5f224f99e 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -5626,8 +5626,6 @@ values of all the exported APIs match the platform that libc is compiled for.")
(lambda* (#:key inputs #:allow-other-keys)
(let ((openssl (assoc-ref inputs "openssl")))
(setenv "OPENSSL_DIR" openssl))
- (setenv "LIBGIT2_SYS_USE_PKG_CONFIG" "1")
- (setenv "LIBSSH2_SYS_USE_PKG_CONFIG" "1")
#t)))))
(native-inputs
`(("libgit2" ,libgit2)
@@ -5734,7 +5732,6 @@ functions and static variables these libraries contain.")
(lambda* (#:key inputs #:allow-other-keys)
(let ((openssl (assoc-ref inputs "openssl")))
(setenv "OPENSSL_DIR" openssl))
- (setenv "LIBSSH2_SYS_USE_PKG_CONFIG" "1")
#t)))))
(native-inputs
`(("libssh2" ,libssh2)
diff --git a/gnu/packages/rust-apps.scm b/gnu/packages/rust-apps.scm
index d9a672f777..90bd146442 100644
--- a/gnu/packages/rust-apps.scm
+++ b/gnu/packages/rust-apps.scm
@@ -143,9 +143,7 @@ gitignore rules.")
(add-after 'configure 'unvendor-libraries-from-crates
(lambda* (#:key inputs #:allow-other-keys)
(let ((openssl (assoc-ref inputs "openssl")))
- (setenv "OPENSSL_DIR" openssl)
- (setenv "LIBGIT2_SYS_USE_PKG_CONFIG" "1")
- (setenv "LIBSSH2_SYS_USE_PKG_CONFIG" "1"))
+ (setenv "OPENSSL_DIR" openssl))
#t)))))
(native-inputs
`(("libgit2" ,libgit2)
diff --git a/guix/build/cargo-build-system.scm b/guix/build/cargo-build-system.scm
index 78c27a29e4..0721989589 100644
--- a/guix/build/cargo-build-system.scm
+++ b/guix/build/cargo-build-system.scm
@@ -119,6 +119,8 @@ directory = '" port)
;; upgrading the compiler for example.
(setenv "RUSTFLAGS" "--cap-lints allow")
(setenv "CC" (string-append (assoc-ref inputs "gcc") "/bin/gcc"))
+ (setenv "LIBGIT2_SYS_USE_PKG_CONFIG" "1")
+ (setenv "LIBSSH2_SYS_USE_PKG_CONFIG" "1")
;; We don't use the Cargo.lock file to determine the package versions we use
;; during building, and in any case if one is not present it is created