summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/gl.scm10
-rw-r--r--gnu/packages/vulkan.scm8
-rw-r--r--guix/build/ant-build-system.scm10
3 files changed, 14 insertions, 14 deletions
diff --git a/gnu/packages/gl.scm b/gnu/packages/gl.scm
index 9ed043c7ae..0f88e9695a 100644
--- a/gnu/packages/gl.scm
+++ b/gnu/packages/gl.scm
@@ -64,14 +64,14 @@
(define-public glu
(package
(name "glu")
- (version "9.0.0")
+ (version "9.0.1")
(source (origin
(method url-fetch)
(uri (string-append "ftp://ftp.freedesktop.org/pub/mesa/glu/glu-"
version ".tar.gz"))
(sha256
(base32
- "0r72yyhj09x3krn3kn629jqbwyq50ji8w5ri2pn6zwrk35m4g1s3"))))
+ "1xqhk9bn10nbvffw3r4p4rjslwz1l7gaycc0x2pqkr2irp7q9x7n"))))
(build-system gnu-build-system)
(propagated-inputs
`(("mesa" ,mesa))) ; according to glu.pc
@@ -224,7 +224,7 @@ also known as DXTn or DXTC) for Mesa.")
(define-public mesa
(package
(name "mesa")
- (version "19.1.1")
+ (version "19.1.3")
(source
(origin
(method url-fetch)
@@ -236,7 +236,7 @@ also known as DXTn or DXTC) for Mesa.")
version "/mesa-" version ".tar.xz")))
(sha256
(base32
- "10amy5sdmpjbskr3xazgk0jyli8xpgi0y1nsmjr76hx8nhb4n4bj"))
+ "1q5p4mw7zrklwx1is09knnb762zzk33xwhwp99fw25ax4ar60m44"))
(patches
(search-patches "mesa-skip-disk-cache-test.patch"))))
(build-system meson-build-system)
@@ -288,7 +288,7 @@ also known as DXTn or DXTC) for Mesa.")
;; TODO: Fix svga driver for aarch64 and armhf.
'("-Dgallium-drivers=etnaviv,freedreno,nouveau,r300,r600,swrast,tegra,v3d,vc4,virgl"))
(_
- '("-Dgallium-drivers=nouveau,r300,r600,radeonsi,svga,swrast,virgl")))
+ '("-Dgallium-drivers=iris,nouveau,r300,r600,radeonsi,svga,swrast,virgl")))
;; Enable various optional features. TODO: opencl requires libclc,
;; omx requires libomxil-bellagio
"-Dplatforms=x11,drm,surfaceless,wayland"
diff --git a/gnu/packages/vulkan.scm b/gnu/packages/vulkan.scm
index 9fb780de77..0b3d476fa2 100644
--- a/gnu/packages/vulkan.scm
+++ b/gnu/packages/vulkan.scm
@@ -159,7 +159,7 @@ interpretation of the specifications for these languages.")
(define-public vulkan-headers
(package
(name "vulkan-headers")
- (version "1.1.112")
+ (version "1.1.114")
(source
(origin
(method git-fetch)
@@ -169,7 +169,7 @@ interpretation of the specifications for these languages.")
(file-name (git-file-name name version))
(sha256
(base32
- "0iia2wlq38hvxwip6r3k5946ylrlk42fw50mhf0pdjxjh02p8zn5"))))
+ "0fdvh26nxibylh32lj8b62d9nf9j25xa0il9zg362wmr2zgm8gka"))))
(build-system cmake-build-system)
(arguments
`(#:tests? #f)) ; No tests.
@@ -193,7 +193,7 @@ interpretation of the specifications for these languages.")
(file-name (git-file-name name version))
(sha256
(base32
- "1819bgmpjlikcc25bkmwwb7mp1rlyrq2v74wybg1g40ix70v0m0d"))))
+ "1rkm6dzdzxva62shscipz3kpp66x4kgmwvp1ski2fvf4jzzcbv7h"))))
(build-system cmake-build-system)
(arguments
`(#:tests? #f ;FIXME: 23/39 tests fail. Try "tests/run_all_tests.sh".
@@ -266,7 +266,7 @@ and the ICD.")
(file-name (git-file-name name version))
(sha256
(base32
- "0an9hqvvpfmfld2pkszzwi7ccb9g2ijjqqzlj24dqg9kqnmcr3x4"))))
+ "1lz06mpni8ghf1xcxi4g6ck306lfaqwfi6f1w64kp9hczmvapfhf"))))
(build-system cmake-build-system)
(inputs
`(("glslang" ,glslang)
diff --git a/guix/build/ant-build-system.scm b/guix/build/ant-build-system.scm
index d79a2d55ed..49549c1b4b 100644
--- a/guix/build/ant-build-system.scm
+++ b/guix/build/ant-build-system.scm
@@ -43,7 +43,8 @@
(call-with-output-file "build.xml"
(lambda (port)
(sxml->xml
- `(project (@ (basedir "."))
+ `(project (@ (basedir ".")
+ (name ,jar-name))
(property (@ (name "classes.dir")
(value "${basedir}/build/classes")))
(property (@ (name "manifest.dir")
@@ -118,10 +119,9 @@
(target (@ (name "jar")
(depends "compile, manifest"))
(mkdir (@ (dir "${jar.dir}")))
- (exec (@ (executable "jar"))
- (arg (@ (line ,(string-append "-cmf ${manifest.file} "
- "${jar.dir}/" jar-name
- " -C ${classes.dir} ."))))))
+ (jar (@ (destfile ,(string-append "${jar.dir}/" jar-name))
+ (manifest "${manifest.file}")
+ (basedir "${classes.dir}"))))
(target (@ (name "install"))
(copy (@ (todir "${dist.dir}"))