summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/ocaml.scm11
1 files changed, 11 insertions, 0 deletions
diff --git a/gnu/packages/ocaml.scm b/gnu/packages/ocaml.scm
index f5becb6bf4..ebe2618e6e 100644
--- a/gnu/packages/ocaml.scm
+++ b/gnu/packages/ocaml.scm
@@ -811,6 +811,7 @@ Knuth’s LR(1) parser construction technique.")
(substitute* "config.make"
((ocaml) out))
#t))))))
+ (properties `((ocaml4.07-variant . ,(delay ocaml4.07-lablgtk))))
(home-page "http://lablgtk.forge.ocamlcore.org/")
(synopsis "GTK+ bindings for OCaml")
(description
@@ -824,6 +825,16 @@ libglade (and it an generate OCaml code from .glade files),
libpanel, librsvg and quartz.")
(license license:lgpl2.1)))
+(define-public ocaml4.07-lablgtk
+ (package
+ (inherit lablgtk)
+ (name "ocaml4.07-lablgtk")
+ (native-inputs
+ `(("ocaml" ,ocaml-4.07)
+ ("findlib" ,ocaml4.07-findlib)
+ ("pkg-config" ,pkg-config)))
+ (properties '())))
+
(define-public unison
(package
(name "unison")