summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/dns.scm11
1 files changed, 8 insertions, 3 deletions
diff --git a/gnu/packages/dns.scm b/gnu/packages/dns.scm
index e5148d5bc9..3091444ed6 100644
--- a/gnu/packages/dns.scm
+++ b/gnu/packages/dns.scm
@@ -680,11 +680,16 @@ synthesis, and on-the-fly re-configuration.")
"09ffmqx79lv5psr433x4n946njgsn071b9b7161pcb9bmrqz380c"))))
(build-system meson-build-system)
(arguments
- '(#:configure-flags
- '("-Dmanaged_ta=disabled" ; we'll manage the DNS root data ourself
- "-Ddoc=enabled")
+ '(#:configure-flags '("-Ddoc=enabled")
#:phases
(modify-phases %standard-phases
+ (add-before 'configure 'disable-default-ta
+ (lambda _
+ ;; Disable the default managed root TA, since we don't have
+ ;; write access to the keyfile and its directory in store.
+ (substitute* "daemon/lua/sandbox.lua.in"
+ (("^trust_anchors\\.add_file.*") ""))
+ #t))
(add-after 'build 'build-doc
(lambda _
(invoke "ninja" "doc")))