summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/hurd.scm7
1 files changed, 3 insertions, 4 deletions
diff --git a/gnu/packages/hurd.scm b/gnu/packages/hurd.scm
index 8dd976ab62..3ab3446d96 100644
--- a/gnu/packages/hurd.scm
+++ b/gnu/packages/hurd.scm
@@ -228,10 +228,9 @@ Hurd-minimal package which are needed for both glibc and GCC.")
(lambda* (#:key outputs #:allow-other-keys)
(let* ((out (assoc-ref outputs "out"))
(boot (string-append out "/boot")))
- (and (zero? (system* "make" "gnumach.gz"))
- (begin
- (install-file "gnumach.gz" boot)
- #t))))))))
+ (invoke "make" "gnumach.gz")
+ (install-file "gnumach.gz" boot)
+ #t))))))
(native-inputs
`(("mig" ,mig)
("perl" ,perl)))