summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/scheme.scm13
1 files changed, 12 insertions, 1 deletions
diff --git a/gnu/packages/scheme.scm b/gnu/packages/scheme.scm
index 1e66750b01..4d717128d9 100644
--- a/gnu/packages/scheme.scm
+++ b/gnu/packages/scheme.scm
@@ -128,7 +128,7 @@ development cycle.")
"1771z43nmf9awjvlvrpjfhzcfxsbw2qipir8g9r47sygf2vn59yl"))))
(build-system gnu-build-system)
(arguments
- '(#:patches (list (assoc-ref %build-inputs "patch/shebangs"))
+ `(#:patches (list (assoc-ref %build-inputs "patch/shebangs"))
#:test-target "test"
#:phases (alist-replace
'configure
@@ -138,6 +138,17 @@ development cycle.")
(("^shell=.*$")
(string-append "shell=" (which "bash") "\n")))
+ ;; Since libgc's pthread redirects are used, we end up
+ ;; using libgc symbols, so we must link against it.
+ ;; Reported on 2013-06-25.
+ (substitute* "api/pthread/src/Makefile"
+ (("^EXTRALIBS[[:blank:]]*=(.*)$" _ value)
+ (string-append "EXTRALIBS = "
+ (string-trim-right value)
+ " -l$(GCLIB)_fth-$(RELEASE)"
+ " -Wl,-rpath=" (assoc-ref outputs "out")
+ "/lib/bigloo/" ,version)))
+
;; Those variables are used by libgc's `configure'.
(setenv "SHELL" (which "bash"))
(setenv "CONFIG_SHELL" (which "bash"))