summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/xiph.scm27
1 files changed, 26 insertions, 1 deletions
diff --git a/gnu/packages/xiph.scm b/gnu/packages/xiph.scm
index 6bd6658035..0e8cb5fafc 100644
--- a/gnu/packages/xiph.scm
+++ b/gnu/packages/xiph.scm
@@ -2,6 +2,7 @@
;;; Copyright © 2013 Andreas Enge <andreas@enge.fr>
;;; Copyright © 2013 Nikita Karetnikov <nikita@karetnikov.org>
;;; Copyright © 2013 David Thompson <dthompson2@worcester.edu>
+;;; Copyright © 2014 Sree Harsha Totakura <sreeharsha@totakura.in>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -40,7 +41,8 @@
ao
flac
libkate
- vorbis-tools))
+ vorbis-tools
+ opus))
(define libogg
(package
@@ -278,3 +280,26 @@ ogginfo, to obtain information (tags, bitrate, length, etc.) about
an ogg vorbis file.")
(license license:gpl2)
(home-page "http://xiph.org/vorbis/")))
+
+(define opus
+ (package
+ (name "opus")
+ (version "1.1")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append
+ "http://downloads.xiph.org/releases/opus/opus-" version
+ ".tar.gz"))
+ (sha256
+ (base32
+ "158xprn2086arvdib3vbbygz7z6jqkw2nci7nlywzzwallap0wmr"))))
+ (build-system gnu-build-system)
+ (synopsis "highly versatile audio codec")
+ (description
+ "Opus is a totally open, royalty-free, highly versatile audio codec. Opus
+is unmatched for interactive speech and music transmission over the Internet,
+but is also intended for storage and streaming applications. It is
+standardized by the Internet Engineering Task Force (IETF) as RFC 6716 which
+incorporated technology from Skype's SILK codec and Xiph.Org's CELT codec.")
+ (license license:bsd-3)
+ (home-page "http://www.opus-codec.org/")))