summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--gnu-system.am4
-rw-r--r--gnu/packages/apr.scm (renamed from gnu/packages/libapr.scm)18
-rw-r--r--gnu/packages/patches/apr-skip-getservbyname-test.patch (renamed from gnu/packages/patches/libapr-skip-getservbyname-test.patch)0
-rw-r--r--gnu/packages/version-control.scm6
4 files changed, 14 insertions, 14 deletions
diff --git a/gnu-system.am b/gnu-system.am
index bfead6efb9..6b10c8508d 100644
--- a/gnu-system.am
+++ b/gnu-system.am
@@ -24,6 +24,7 @@ GNU_SYSTEM_MODULES = \
gnu/packages.scm \
gnu/packages/acl.scm \
gnu/packages/algebra.scm \
+ gnu/packages/apr.scm \
gnu/packages/aspell.scm \
gnu/packages/attr.scm \
gnu/packages/autotools.scm \
@@ -87,7 +88,6 @@ GNU_SYSTEM_MODULES = \
gnu/packages/ld-wrapper.scm \
gnu/packages/less.scm \
gnu/packages/lesstif.scm \
- gnu/packages/libapr.scm \
gnu/packages/libdaemon.scm \
gnu/packages/libevent.scm \
gnu/packages/libffi.scm \
@@ -173,6 +173,7 @@ GNU_SYSTEM_MODULES = \
patchdir = $(guilemoduledir)/gnu/packages/patches
dist_patch_DATA = \
+ gnu/packages/patches/apr-skip-getservbyname-test.patch \
gnu/packages/patches/automake-skip-amhello-tests.patch \
gnu/packages/patches/bigloo-gc-shebangs.patch \
gnu/packages/patches/binutils-ld-new-dtags.patch \
@@ -196,7 +197,6 @@ dist_patch_DATA = \
gnu/packages/patches/guile-default-utf8.patch \
gnu/packages/patches/guile-linux-syscalls.patch \
gnu/packages/patches/guile-relocatable.patch \
- gnu/packages/patches/libapr-skip-getservbyname-test.patch \
gnu/packages/patches/libevent-dns-tests.patch \
gnu/packages/patches/libtool-skip-tests.patch \
gnu/packages/patches/m4-gets-undeclared.patch \
diff --git a/gnu/packages/libapr.scm b/gnu/packages/apr.scm
index 9ace167806..01a4e6c2ba 100644
--- a/gnu/packages/libapr.scm
+++ b/gnu/packages/apr.scm
@@ -16,7 +16,7 @@
;;; You should have received a copy of the GNU General Public License
;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
-(define-module (gnu packages libapr)
+(define-module (gnu packages apr)
#:use-module (guix licenses)
#:use-module (guix packages)
#:use-module (guix download)
@@ -25,9 +25,9 @@
#:use-module (gnu packages perl)
#:use-module (gnu packages autotools))
-(define-public libapr
+(define-public apr
(package
- (name "libapr")
+ (name "apr")
(version "1.4.8")
(source (origin
(method url-fetch)
@@ -44,7 +44,7 @@
(inputs `(("perl" ,perl)
("libtool" ,libtool)
("patch/skip-test"
- ,(search-patch "libapr-skip-getservbyname-test.patch"))))
+ ,(search-patch "apr-skip-getservbyname-test.patch"))))
(home-page "http://apr.apache.org/")
(synopsis "The Apache Portable Runtime Library")
(description
@@ -57,9 +57,9 @@ built, relieving them of the need to code special-case conditions to work
around or take advantage of platform-specific deficiencies or features.")
(license asl2.0)))
-(define-public libaprutil
+(define-public apr-util
(package
- (name "libaprutil")
+ (name "apr-util")
(version "1.5.2")
(source (origin
(method url-fetch)
@@ -70,19 +70,19 @@ around or take advantage of platform-specific deficiencies or features.")
"19qjxpckb9p4j9pbk8kcirg6k5vqnjrqhnk9xx2c5m9964p3vkls"))))
(build-system gnu-build-system)
(inputs
- `(("libapr" ,libapr)))
+ `(("apr" ,apr)))
(arguments
'(#:phases
(alist-replace
'configure
(lambda* (#:key inputs outputs #:allow-other-keys)
(let ((out (assoc-ref outputs "out"))
- (libapr (assoc-ref inputs "libapr")))
+ (apr (assoc-ref inputs "apr")))
(setenv "CONFIG_SHELL" (which "bash"))
(zero?
(system* "./configure"
(string-append "--prefix=" out)
- (string-append "--with-apr=" libapr)))))
+ (string-append "--with-apr=" apr)))))
%standard-phases)))
(home-page "http://apr.apache.org/")
(synopsis "One of the Apache Portable Runtime Library companions")
diff --git a/gnu/packages/patches/libapr-skip-getservbyname-test.patch b/gnu/packages/patches/apr-skip-getservbyname-test.patch
index e12a8eb56c..e12a8eb56c 100644
--- a/gnu/packages/patches/libapr-skip-getservbyname-test.patch
+++ b/gnu/packages/patches/apr-skip-getservbyname-test.patch
diff --git a/gnu/packages/version-control.scm b/gnu/packages/version-control.scm
index de6aaf8344..5059dcd5e1 100644
--- a/gnu/packages/version-control.scm
+++ b/gnu/packages/version-control.scm
@@ -27,7 +27,7 @@
#:use-module (guix build utils)
#:use-module ((gnu packages gettext)
#:renamer (symbol-prefix-proc 'guix:))
- #:use-module (gnu packages libapr)
+ #:use-module (gnu packages apr)
#:use-module (gnu packages nano)
#:use-module (gnu packages perl)
#:use-module (gnu packages python)
@@ -77,8 +77,8 @@ from a command line or use a GUI application.")
"11inl9n1riahfnbk1fax0dysm2swakzhzhpmm2zvga6fikcx90zw"))))
(build-system gnu-build-system)
(inputs
- `(("libapr" ,libapr)
- ("libaprutil" ,libaprutil)
+ `(("apr" ,apr)
+ ("apr-util" ,apr-util)
("perl" ,perl)
("python" ,python)
("sqlite" ,sqlite)