summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/bioinformatics.scm4
1 files changed, 2 insertions, 2 deletions
diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index f5901703ce..f976cad22f 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -1767,8 +1767,8 @@ well as many of the command line options.")
(add-after 'unpack 'keep-references-to-bwa
(lambda* (#:key inputs #:allow-other-keys)
(substitute* "bwameth.py"
- (("bwa mem")
- (string-append (which "bwa") " mem"))
+ (("bwa (mem|index)" _ command)
+ (string-append (which "bwa") " " command))
;; There's an ill-advised check for "samtools" on PATH.
(("^checkX.*") ""))
#t)))))