summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/embedded.scm4
1 files changed, 2 insertions, 2 deletions
diff --git a/gnu/packages/embedded.scm b/gnu/packages/embedded.scm
index 004d082470..1e7fd098cb 100644
--- a/gnu/packages/embedded.scm
+++ b/gnu/packages/embedded.scm
@@ -575,7 +575,7 @@ with a layered architecture of JTAG interface and TAP support.")
;; have to create the target directories at build time.
(add-before 'build 'create-target-directories
(lambda* (#:key make-flags #:allow-other-keys)
- (zero? (apply system* "make" "install-dirs" make-flags))))
+ (apply invoke "make" "install-dirs" make-flags)))
(add-before 'build 'set-cross-environment-variables
(lambda* (#:key outputs #:allow-other-keys)
(setenv "CROSS_LIBRARY_PATH"
@@ -589,7 +589,7 @@ with a layered architecture of JTAG interface and TAP support.")
#t))
(add-before 'install 'install-includes
(lambda* (#:key make-flags #:allow-other-keys)
- (zero? (apply system* "make" "install-includes" make-flags)))))))
+ (apply invoke "make" "install-includes" make-flags))))))
(native-inputs
`(("propeller-gcc" ,propeller-gcc)
("propeller-binutils" ,propeller-binutils)