aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/crates-io.scm23
1 files changed, 23 insertions, 0 deletions
diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index 4056bda330..f64aa74390 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -4408,6 +4408,29 @@ process and much more.")
"This package provides cross-platform file locks and file duplication.")
(license (list license:expat license:asl2.0))))
+(define-public rust-fsevent-sys-2
+ (package
+ (name "rust-fsevent-sys")
+ (version "2.0.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (crate-uri "fsevent-sys" version))
+ (file-name
+ (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32
+ "18246vxk7rqn52m0sfrhivxq802i34p2wqqx5zsa0pamjj5086zl"))))
+ (build-system cargo-build-system)
+ (arguments
+ `(#:skip-build? #t ; only available on macOS
+ #:cargo-inputs (("rust-libc" ,rust-libc-0.2))))
+ (home-page "https://github.com/octplane/fsevent-rust/tree/master/fsevent-sys")
+ (synopsis "Rust bindings to the fsevent macOS API")
+ (description "This package provides Rust bindings to the @code{fsevent}
+macOS API for file changes notifications")
+ (license license:expat)))
+
(define-public rust-fuchsia-cprng-0.1
(package
(name "rust-fuchsia-cprng")