summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/text-editors.scm6
1 files changed, 6 insertions, 0 deletions
diff --git a/gnu/packages/text-editors.scm b/gnu/packages/text-editors.scm
index 7357df7fb3..7843c120aa 100644
--- a/gnu/packages/text-editors.scm
+++ b/gnu/packages/text-editors.scm
@@ -261,6 +261,12 @@ Wordstar-, EMACS-, Pico, Nedit or vi-like key bindings. e3 can be used on
"CC=gcc")
#:phases (modify-phases %standard-phases
(delete 'configure)
+ (add-before 'build 'correct-location-of-difftool
+ (lambda _
+ (substitute* "buffer.c"
+ (("/usr/bin/diff")
+ (which "diff")))
+ #t))
(add-before 'install 'patch-tutorial-location
(lambda* (#:key outputs #:allow-other-keys)
(substitute* "mg.1"