summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/crates-io.scm23
1 files changed, 23 insertions, 0 deletions
diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index a54789fc88..e35cf774b5 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -7430,6 +7430,29 @@ checking.")
"Chaining APIs for both self -> Self and &mut self methods.")
(license license:expat)))
+(define-public rust-named-pipe-0.4
+ (package
+ (name "rust-named-pipe")
+ (version "0.4.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (crate-uri "named-pipe" version))
+ (file-name
+ (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32
+ "0azby10wzmsrf66m1bysbil0sjfybnvhsa8py093xz4irqy4975d"))))
+ (build-system cargo-build-system)
+ (arguments
+ `(#:skip-build? #t ; Only builds on Windows.
+ #:cargo-inputs (("rust-winapi" ,rust-winapi-0.3))))
+ (home-page "https://github.com/blackbeam/named_pipe")
+ (synopsis "Wrapper for overlapped (asyncronous) IO of Windows's named pipes")
+ (description "This package provides a wrapper for overlapped (asyncronous)
+IO of Windows's named pipes.")
+ (license (list license:expat license:asl2.0))))
+
(define-public rust-natord-1.0
(package
(name "rust-natord")