summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/bootloaders.scm1
-rw-r--r--gnu/packages/debug.scm2
2 files changed, 2 insertions, 1 deletions
diff --git a/gnu/packages/bootloaders.scm b/gnu/packages/bootloaders.scm
index 70b392f3c1..9ea8748a5b 100644
--- a/gnu/packages/bootloaders.scm
+++ b/gnu/packages/bootloaders.scm
@@ -74,6 +74,7 @@
;; The GRUB test suite fails with later versions of Qemu, so we
;; keep it at 2.10 for now. See
;; <https://lists.gnu.org/archive/html/bug-grub/2018-02/msg00004.html>.
+;; TODO: When grub no longer needs this version, move to gnu/packages/debug.scm.
(define qemu-minimal-2.10
(package
(inherit qemu-minimal)
diff --git a/gnu/packages/debug.scm b/gnu/packages/debug.scm
index 09efcbdd6c..2354f0fbb9 100644
--- a/gnu/packages/debug.scm
+++ b/gnu/packages/debug.scm
@@ -169,7 +169,7 @@ tools that process C/C++ code.")
(inputs
`(("custom-qemu"
;; The afl-qemu tool builds qemu 2.10.0 with a few patches applied.
- ,(package (inherit qemu-minimal)
+ ,(package (inherit (@@ (gnu packages bootloaders) qemu-minimal-2.10))
(name "afl-qemu")
(inputs
`(("afl-src" ,source)