summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--gnu-system.am1
-rw-r--r--gnu/packages/xdisorg.scm33
-rw-r--r--gnu/packages/xlockmore.scm56
3 files changed, 33 insertions, 57 deletions
diff --git a/gnu-system.am b/gnu-system.am
index c29b13990b..c520418edc 100644
--- a/gnu-system.am
+++ b/gnu-system.am
@@ -277,7 +277,6 @@ GNU_SYSTEM_MODULES = \
gnu/packages/wv.scm \
gnu/packages/xfig.scm \
gnu/packages/xiph.scm \
- gnu/packages/xlockmore.scm \
gnu/packages/xml.scm \
gnu/packages/xnee.scm \
gnu/packages/xdisorg.scm \
diff --git a/gnu/packages/xdisorg.scm b/gnu/packages/xdisorg.scm
index 2052f7b9be..b48563227c 100644
--- a/gnu/packages/xdisorg.scm
+++ b/gnu/packages/xdisorg.scm
@@ -3,6 +3,7 @@
;;; Copyright © 2014 Mark H Weaver <mhw@netris.org>
;;; Copyright © 2014 Eric Bavier <bavier@member.fsf.org>
;;; Copyright © 2014 Alex Kost <alezost@gmail.com>
+;;; Copyright © 2013, 2015 Ludovic Courtès <ludo@gnu.org>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -30,6 +31,7 @@
#:use-module (gnu packages pkg-config)
#:use-module (gnu packages glib)
#:use-module (gnu packages perl)
+ #:use-module (gnu packages linux)
#:use-module (gnu packages xorg))
;; packages outside the x.org system proper
@@ -359,3 +361,34 @@ invisible cursor. This allows you to see all the text in an xterm or
xedit, for example. The human factors crowd would agree it should make
things less distracting.")
(license license:public-domain)))
+
+(define-public xlockmore
+ (package
+ (name "xlockmore")
+ (version "5.45")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "http://www.tux.org/~bagleyd/xlock/xlockmore-"
+ version "/xlockmore-" version ".tar.bz2"))
+ (sha256
+ (base32
+ "1xqm61bbfn5q056w57vp16gvai8nqpcw570ysxlm5h46nh6ai0bz"))))
+ (build-system gnu-build-system)
+ (arguments
+ '(#:configure-flags (list (string-append "--enable-appdefaultdir="
+ (assoc-ref %outputs "out")
+ "/lib/X11/app-defaults"))
+ #:tests? #f)) ;no such thing as a test suite
+ (inputs
+ `(("libX11" ,libx11)
+ ("libXext" ,libxext)
+ ("libXt" ,libxt)
+ ("linux-pam" ,linux-pam)))
+ (home-page "http://www.tux.org/~bagleyd/xlockmore.html")
+ (synopsis "Screen locker for the X Window System")
+ (description
+ "XLockMore is a classic screen locker and screen saver for the
+X Window System.")
+ (license (license:bsd-style #f "See xlock.c.")
+ ;; + GPLv2 in modes/glx/biof.c.
+ )))
diff --git a/gnu/packages/xlockmore.scm b/gnu/packages/xlockmore.scm
deleted file mode 100644
index 75dad1a78c..0000000000
--- a/gnu/packages/xlockmore.scm
+++ /dev/null
@@ -1,56 +0,0 @@
-;;; GNU Guix --- Functional package management for GNU
-;;; Copyright © 2013, 2015 Ludovic Courtès <ludo@gnu.org>
-;;;
-;;; This file is part of GNU Guix.
-;;;
-;;; GNU Guix is free software; you can redistribute it and/or modify it
-;;; under the terms of the GNU General Public License as published by
-;;; the Free Software Foundation; either version 3 of the License, or (at
-;;; your option) any later version.
-;;;
-;;; GNU Guix is distributed in the hope that it will be useful, but
-;;; WITHOUT ANY WARRANTY; without even the implied warranty of
-;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
-;;; GNU General Public License for more details.
-;;;
-;;; You should have received a copy of the GNU General Public License
-;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
-
-(define-module (gnu packages xlockmore)
- #:use-module (guix packages)
- #:use-module (guix download)
- #:use-module (guix build-system gnu)
- #:use-module (guix licenses)
- #:use-module (gnu packages xorg)
- #:use-module (gnu packages linux))
-
-(define-public xlockmore
- (package
- (name "xlockmore")
- (version "5.45")
- (source (origin
- (method url-fetch)
- (uri (string-append "http://www.tux.org/~bagleyd/xlock/xlockmore-"
- version "/xlockmore-" version ".tar.bz2"))
- (sha256
- (base32
- "1xqm61bbfn5q056w57vp16gvai8nqpcw570ysxlm5h46nh6ai0bz"))))
- (build-system gnu-build-system)
- (arguments
- '(#:configure-flags (list (string-append "--enable-appdefaultdir="
- (assoc-ref %outputs "out")
- "/lib/X11/app-defaults"))
- #:tests? #f)) ;no such thing as a test suite
- (inputs
- `(("libX11" ,libx11)
- ("libXext" ,libxext)
- ("libXt" ,libxt)
- ("linux-pam" ,linux-pam)))
- (home-page "http://www.tux.org/~bagleyd/xlockmore.html")
- (synopsis "Screen locker for the X Window System")
- (description
- "XLockMore is a classic screen locker and screen saver for the
-X Window System.")
- (license (bsd-style #f "See xlock.c.")
- ;; + GPLv2 in modes/glx/biof.c.
- )))