summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/gstreamer.scm11
1 files changed, 5 insertions, 6 deletions
diff --git a/gnu/packages/gstreamer.scm b/gnu/packages/gstreamer.scm
index 3aec87e25f..45dded1a6e 100644
--- a/gnu/packages/gstreamer.scm
+++ b/gnu/packages/gstreamer.scm
@@ -180,12 +180,11 @@ This package provides the core library and elements.")
(assoc-ref %outputs "doc")
"/share/gtk-doc/html"))
#:phases
- (alist-cons-before
- 'configure 'patch
- (lambda _
- (substitute* "tests/check/libs/pbutils.c"
- (("/bin/sh") (which "sh"))))
- %standard-phases)))
+ (modify-phases %standard-phases
+ (add-before 'configure 'patch
+ (lambda _
+ (substitute* "tests/check/libs/pbutils.c"
+ (("/bin/sh") (which "sh"))))))))
(home-page "http://gstreamer.freedesktop.org/")
(synopsis
"Plugins for the GStreamer multimedia library")