summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/check.scm24
-rw-r--r--gnu/packages/cpp.scm2
2 files changed, 24 insertions, 2 deletions
diff --git a/gnu/packages/check.scm b/gnu/packages/check.scm
index 6619142b50..f61e96422b 100644
--- a/gnu/packages/check.scm
+++ b/gnu/packages/check.scm
@@ -196,7 +196,7 @@ supervised tests.")
multi-paradigm automated test framework for C++ and Objective-C.")
(license license:boost1.0)))
-(define-public catch-framework2
+(define-public catch-framework2-1
(package
(name "catch2")
(version "1.12.2")
@@ -216,6 +216,28 @@ multi-paradigm automated test framework for C++ and Objective-C.")
a multi-paradigm automated test framework for C++ and Objective-C.")
(license license:boost1.0)))
+(define-public catch-framework2
+ (package
+ (name "catch2")
+ (version "2.1.2")
+ (home-page "https://github.com/catchorg/Catch2")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/catchorg/Catch2")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "14vcckqmbydjsg40ngi6iv999zimysh2l7fmrqj1d7xl990qz233"))))
+ (build-system cmake-build-system)
+ (inputs
+ `(("python" ,python-wrapper)))
+ (synopsis "Automated test framework for C++ and Objective-C")
+ (description "Catch2 stands for C++ Automated Test Cases in Headers and is
+a multi-paradigm automated test framework for C++ and Objective-C.")
+ (license license:boost1.0)))
+
(define-public cmdtest
(package
(name "cmdtest")
diff --git a/gnu/packages/cpp.scm b/gnu/packages/cpp.scm
index 335f9a65cd..ae1e3e3356 100644
--- a/gnu/packages/cpp.scm
+++ b/gnu/packages/cpp.scm
@@ -185,7 +185,7 @@ batches.")
(modules '((guix build utils)))
(snippet '(delete-file-recursively "./test/thirdparty"))))
(native-inputs
- `(("catch2" ,catch-framework2)))
+ `(("catch2" ,catch-framework2-1)))
(build-system cmake-build-system)
(arguments
`(#:phases