summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--Makefile.am2
-rw-r--r--gnu/local.mk6
2 files changed, 5 insertions, 3 deletions
diff --git a/Makefile.am b/Makefile.am
index 9484ba75aa..c75be9c842 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -379,7 +379,7 @@ check-local:
endif !CAN_RUN_TESTS
-check-system: $(GOBJECTS)
+check-system: $(GOBJECTS) $(BOOTSTRAP_GUILE_TARBALLS)
$(AM_V_at)$(top_builddir)/pre-inst-env \
$(GUILE) --no-auto-compile \
-e '(@@ (run-system-tests) run-system-tests)' \
diff --git a/gnu/local.mk b/gnu/local.mk
index 52000a2c53..28ab73aed3 100644
--- a/gnu/local.mk
+++ b/gnu/local.mk
@@ -1087,13 +1087,15 @@ nodist_bootstrap_mips64el_linux_DATA = \
set-bootstrap-executable-permissions:
chmod +x $(DESTDIR)$(bootstrapdir)/*/{bash,mkdir,tar,xz}
-DISTCLEANFILES = \
+BOOTSTRAP_GUILE_TARBALLS = \
$(nodist_bootstrap_x86_64_linux_DATA) \
$(nodist_bootstrap_i686_linux_DATA) \
$(nodist_bootstrap_armhf_linux_DATA) \
- $(nodist_bootstrap_aarch64_linux_DATA) \
+ $(nodist_bootstrap_aarch64_linux_DATA) \
$(nodist_bootstrap_mips64el_linux_DATA)
+DISTCLEANFILES = $(BOOTSTRAP_GUILE_TARBALLS)
+
# Method to download a file from an external source.
DOWNLOAD_FILE = \
GUILE_LOAD_COMPILED_PATH="$(top_builddir):$$GUILE_LOAD_COMPILED_PATH" \