summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/guile.scm25
1 files changed, 16 insertions, 9 deletions
diff --git a/gnu/packages/guile.scm b/gnu/packages/guile.scm
index cb14f0e6c7..787bc16965 100644
--- a/gnu/packages/guile.scm
+++ b/gnu/packages/guile.scm
@@ -373,17 +373,24 @@ http:://json.org specification. These are the main features:
"1l8xcqq4cp67jzxnmf07ivsgq23mfmi00zz1s8bnv2zkb0ab9475"))
(modules '((guix build utils)))
(snippet
- ;; Remove dependency from guile-charting.texi to
- ;; guile-chartingscmfiles to avoid rebuild the doc (which is
- ;; unnecessary and fails with "failed to match any pattern in
- ;; form define-macro-with-docs" as of Guile 2.0.11.)
- '(substitute* "doc/Makefile.in"
- (("^(.+):(.*) \\$\\(doc\\)scmfiles(.*$)" _ target dep1 dep2)
- (string-append target ":" dep1 " " dep2 "\n"))))))
+ '(begin
+ ;; Use the standard versioned location for modules.
+ (substitute* '("Makefile.in" "charting/Makefile.in")
+ (("/share/guile/site")
+ "/share/guile/site/2.0"))
+
+ ;; Remove dependency from guile-charting.texi to
+ ;; guile-chartingscmfiles to avoid rebuild the doc (which is
+ ;; unnecessary and fails with "failed to match any pattern
+ ;; in form define-macro-with-docs" as of Guile 2.0.11.)
+ (substitute* "doc/Makefile.in"
+ (("^(.+):(.*) \\$\\(doc\\)scmfiles(.*$)" _ target
+ dep1 dep2)
+ (string-append target ":" dep1 " " dep2 "\n")))))))
(build-system gnu-build-system)
(native-inputs `(("pkg-config" ,pkg-config)))
- (inputs `(("guile" ,guile-2.0)
- ("guile-cairo" ,guile-cairo)))
+ (inputs `(("guile" ,guile-2.0)))
+ (propagated-inputs `(("guile-cairo" ,guile-cairo)))
(home-page "http://wingolog.org/software/guile-charting/")
(synopsis "Create charts and graphs in Guile")
(description