summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/linux.scm6
1 files changed, 6 insertions, 0 deletions
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index 4ccf613a9b..22f001d040 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -3271,6 +3271,12 @@ arrays when needed.")
(string-append "DESTDIR="
(assoc-ref %outputs "out"))
"SYSTEMDPATH=lib"
+ ;; Add the libaio headers to GCCs system header
+ ;; search path to suppress -Werror=cast-qual on
+ ;; the included headers.
+ (string-append "C_INCLUDE_PATH="
+ (assoc-ref %build-inputs "libaio")
+ "/include")
(string-append "LDFLAGS=-Wl,-rpath="
(assoc-ref %outputs "out")
"/lib"))