summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/benchmark.scm5
1 files changed, 3 insertions, 2 deletions
diff --git a/gnu/packages/benchmark.scm b/gnu/packages/benchmark.scm
index bf88bd4919..ebc8bdb5f2 100644
--- a/gnu/packages/benchmark.scm
+++ b/gnu/packages/benchmark.scm
@@ -67,8 +67,9 @@
;; The configure script doesn't understand some of the
;; GNU options, so we can't use #:configure-flags.
(let ((out (assoc-ref outputs "out")))
- (zero? (system* "./configure"
- (string-append "--prefix=" out))))))
+ (invoke "./configure"
+ (string-append "--prefix=" out))
+ #t)))
;; The main `fio` executable is fairly small and self contained.
;; Moving the auxiliary python and gnuplot scripts to a separate
;; output saves almost 400 MiB on the closure.