summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--Makefile.am8
-rw-r--r--doc/guix.texi2
-rw-r--r--doc/local.mk (renamed from doc.am)0
-rw-r--r--emacs/guix-config.el.in2
-rw-r--r--emacs/local.mk (renamed from emacs.am)0
-rw-r--r--gnu/local.mk (renamed from gnu-system.am)0
-rw-r--r--guix/config.scm.in4
-rw-r--r--nix/local.mk (renamed from daemon.am)0
8 files changed, 8 insertions, 8 deletions
diff --git a/Makefile.am b/Makefile.am
index 1f257a009c..5cee3d3b6f 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -27,7 +27,7 @@ nodist_noinst_SCRIPTS = \
pre-inst-env \
test-env
-include gnu-system.am
+include gnu/local.mk
MODULES = \
guix/base32.scm \
@@ -416,11 +416,11 @@ install-data-hook: set-bootstrap-executable-permissions
SUBDIRS = po/guix po/packages
BUILT_SOURCES =
-include doc.am
+include doc/local.mk
if BUILD_DAEMON
-include daemon.am
+include nix/local.mk
endif BUILD_DAEMON
@@ -437,7 +437,7 @@ AM_DISTCHECK_CONFIGURE_FLAGS = \
dist_emacsui_DATA = emacs/guix-main.scm
nodist_emacsui_DATA = emacs/guix-helper.scm
-include emacs.am
+include emacs/local.mk
# The self-contained tarball.
guix-binary.%.tar.xz:
diff --git a/doc/guix.texi b/doc/guix.texi
index 859db2be12..ab07d1066e 100644
--- a/doc/guix.texi
+++ b/doc/guix.texi
@@ -11286,7 +11286,7 @@ to be updated to refer to these binaries on the target platform. That
is, the hashes and URLs of the bootstrap tarballs for the new platform
must be added alongside those of the currently supported platforms. The
bootstrap Guile tarball is treated specially: it is expected to be
-available locally, and @file{gnu-system.am} has rules do download it for
+available locally, and @file{gnu/local.mk} has rules do download it for
the supported architectures; a rule for the new platform must be added
as well.
diff --git a/doc.am b/doc/local.mk
index b9f07c3590..b9f07c3590 100644
--- a/doc.am
+++ b/doc/local.mk
diff --git a/emacs/guix-config.el.in b/emacs/guix-config.el.in
index bd821596c4..d03df9ce63 100644
--- a/emacs/guix-config.el.in
+++ b/emacs/guix-config.el.in
@@ -24,7 +24,7 @@
(replace-regexp-in-string "${prefix}" "@prefix@" "@emacsuidir@"))
(defconst guix-config-state-directory
- ;; This must match `NIX_STATE_DIR' as defined in `daemon.am'.
+ ;; This must match `NIX_STATE_DIR' as defined in `nix/local.mk'.
(or (getenv "NIX_STATE_DIR") "@guix_localstatedir@/guix"))
(defconst guix-config-guile-program "@GUILE@"
diff --git a/emacs.am b/emacs/local.mk
index 62e33e4fd2..62e33e4fd2 100644
--- a/emacs.am
+++ b/emacs/local.mk
diff --git a/gnu-system.am b/gnu/local.mk
index d58155a1b5..d58155a1b5 100644
--- a/gnu-system.am
+++ b/gnu/local.mk
diff --git a/guix/config.scm.in b/guix/config.scm.in
index 764e466bc5..d7df9f7d2b 100644
--- a/guix/config.scm.in
+++ b/guix/config.scm.in
@@ -55,11 +55,11 @@
"@storedir@"))
(define %state-directory
- ;; This must match `NIX_STATE_DIR' as defined in `daemon.am'.
+ ;; This must match `NIX_STATE_DIR' as defined in `nix/local.mk'.
(or (getenv "NIX_STATE_DIR") "@guix_localstatedir@/guix"))
(define %config-directory
- ;; This must match `NIX_CONF_DIR' as defined in `daemon.am'.
+ ;; This must match `NIX_CONF_DIR' as defined in `nix/local.mk'.
(or (getenv "NIX_CONF_DIR") "@guix_sysconfdir@/guix"))
(define %guix-register-program
diff --git a/daemon.am b/nix/local.mk
index 3c15531f54..3c15531f54 100644
--- a/daemon.am
+++ b/nix/local.mk