summaryrefslogtreecommitdiff
path: root/tests
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2012-09-10 22:47:10 +0200
committerLudovic Courtès <ludo@gnu.org>2012-09-10 22:47:10 +0200
commitbe13fbfa83dd3e3c7a7a3d09f9c520940eb350d4 (patch)
tree0af29db18eee64b9f3e7e2f55dd98b7ef27d0c90 /tests
parent3c0670e686b33b50f35811f1427bf0d3e1abce41 (diff)
downloadpatches-be13fbfa83dd3e3c7a7a3d09f9c520940eb350d4.tar
patches-be13fbfa83dd3e3c7a7a3d09f9c520940eb350d4.tar.gz
Add (guix build-system trivial).
* guix/build-system/trivial.scm: New file. * Makefile.am (MODULES): Add it. * tests/packages.scm ("trivial"): New test. * guix/packages.scm (package-derivation): Allow SOURCE to be #f.
Diffstat (limited to 'tests')
-rw-r--r--tests/packages.scm20
1 files changed, 19 insertions, 1 deletions
diff --git a/tests/packages.scm b/tests/packages.scm
index d804e0ce83..48a4a38fea 100644
--- a/tests/packages.scm
+++ b/tests/packages.scm
@@ -22,6 +22,7 @@
#:use-module (guix utils)
#:use-module (guix derivations)
#:use-module (guix packages)
+ #:use-module (guix build-system trivial)
#:use-module (guix build-system gnu)
#:use-module (distro)
#:use-module (distro base)
@@ -62,7 +63,24 @@
("d" ,d) ("d/x" "something.drv"))
(pk 'x (package-transitive-inputs e))))))
-(test-skip (if (not %store) 1 0))
+(test-skip (if (not %store) 2 0))
+
+(test-assert "trivial"
+ (let* ((p (package (inherit (dummy-package "trivial"))
+ (build-system trivial-build-system)
+ (source #f)
+ (arguments
+ '(#:builder
+ (begin
+ (mkdir %output)
+ (call-with-output-file (string-append %output "/test")
+ (lambda (p)
+ (display '(hello guix) p))))))))
+ (d (package-derivation %store p)))
+ (and (build-derivations %store (list d))
+ (let ((p (pk 'drv d (derivation-path->output-path d))))
+ (equal? '(hello guix)
+ (call-with-input-file (string-append p "/test") read))))))
(test-assert "GNU Hello"
(and (package? hello)