summaryrefslogtreecommitdiff
path: root/tests
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2013-01-24 23:33:30 +0100
committerLudovic Courtès <ludo@gnu.org>2013-01-24 23:33:51 +0100
commitdd6b9a3790b8d545c7254dedeb81630a6fa1d66a (patch)
tree00f95730c2dde207e545a2b892731eec88de8c29 /tests
parent3b9c00208868a75e6b77445fcd33d82536448bb2 (diff)
downloadpatches-dd6b9a3790b8d545c7254dedeb81630a6fa1d66a.tar
patches-dd6b9a3790b8d545c7254dedeb81630a6fa1d66a.tar.gz
packages: Mark the `inputs' field of <package> as thunked.
* guix/packages.scm (<package>)[inputs]: Mark as thunked. (package-derivation)[expand-input]: Remove case where the input is a procedure. * tests/packages.scm ("trivial with system-dependent input"): Remove `lambda', and use (%current-system). * gnu/packages/bootstrap.scm (package-from-tarball): Likewise for `inputs'. (%bootstrap-glibc, %bootstrap-gcc): Likewise. * gnu/packages/scheme.scm (mit-scheme): Likewise.
Diffstat (limited to 'tests')
-rw-r--r--tests/packages.scm5
1 files changed, 2 insertions, 3 deletions
diff --git a/tests/packages.scm b/tests/packages.scm
index 990deb79ef..8b0f29e6bc 100644
--- a/tests/packages.scm
+++ b/tests/packages.scm
@@ -124,9 +124,8 @@
(bash (assoc-ref %build-inputs "bash")))
(zero? (system* bash "-c"
(format #f "echo hello > ~a" out))))))
- (inputs `(("bash" ,(lambda (system)
- (search-bootstrap-binary "bash"
- system)))))))
+ (inputs `(("bash" ,(search-bootstrap-binary "bash"
+ (%current-system)))))))
(d (package-derivation %store p)))
(and (build-derivations %store (list d))
(let ((p (pk 'drv d (derivation-path->output-path d))))