summaryrefslogtreecommitdiff
path: root/tests
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2020-01-06 01:36:00 -0500
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2020-01-31 23:37:13 -0500
commitd3e439e355284f136ff13eb3e6fffb4661552f3b (patch)
tree624e123167079a142ddacb1c3d7b00e73f7f3490 /tests
parent76f5428bc6b4b4d944be1c16f50d6e558416635f (diff)
downloadpatches-d3e439e355284f136ff13eb3e6fffb4661552f3b.tar
patches-d3e439e355284f136ff13eb3e6fffb4661552f3b.tar.gz
gnu: Add earlyoom-service-type.
* gnu/services/linux.scm: New file. * tests/services/linux.scm: Add test. * Makefile.am (SCM_TESTS): Register test. * doc/guix.texi (Linux Services): Add a new section and document the new service and its configuration.
Diffstat (limited to 'tests')
-rw-r--r--tests/services/linux.scm57
1 files changed, 57 insertions, 0 deletions
diff --git a/tests/services/linux.scm b/tests/services/linux.scm
new file mode 100644
index 0000000000..8ad119c49f
--- /dev/null
+++ b/tests/services/linux.scm
@@ -0,0 +1,57 @@
+;;; GNU Guix --- Functional package management for GNU
+;;; Copyright © 2020 Maxim Cournoyer <maxim.cournoyer@gmail.com>
+;;;
+;;; This file is part of GNU Guix.
+;;;
+;;; GNU Guix is free software; you can redistribute it and/or modify it
+;;; under the terms of the GNU General Public License as published by
+;;; the Free Software Foundation; either version 3 of the License, or (at
+;;; your option) any later version.
+;;;
+;;; GNU Guix is distributed in the hope that it will be useful, but
+;;; WITHOUT ANY WARRANTY; without even the implied warranty of
+;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+;;; GNU General Public License for more details.
+;;;
+;;; You should have received a copy of the GNU General Public License
+;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
+
+(define-module (tests services linux)
+ #:use-module (ice-9 match)
+ #:use-module (gnu packages linux)
+ #:use-module (gnu services linux)
+ #:use-module (guix gexp)
+ #:use-module (srfi srfi-64))
+
+;;; Tests for the (gnu services linux) module.
+
+(test-begin "linux-services")
+
+
+;;;
+;;; Early OOM daemon.
+;;;
+
+(define earlyoom-configuration->command-line-args
+ (@@ (gnu services linux) earlyoom-configuration->command-line-args))
+
+(define %earlyoom-configuration-sample
+ (earlyoom-configuration
+ (minimum-available-memory 10)
+ (minimum-free-swap 20)
+ (prefer-regexp "icecat")
+ (avoid-regexp "guix-daemon")
+ (memory-report-interval 60)
+ (ignore-positive-oom-score-adj? #f)
+ (run-with-higher-priority? #t)
+ (show-debug-messages? #f)
+ (send-notification-command "python \"/some/path/notify-all-users.py\"")))
+
+(test-equal "earlyoom-configuration->command-line-args"
+ (list (file-append earlyoom "/bin/earlyoom")
+ "-m" "10" "-s" "20" "--prefer" "icecat"
+ "--avoid" "guix-daemon" "-r" "60" "-p"
+ "-N" "python \"/some/path/notify-all-users.py\"")
+ (earlyoom-configuration->command-line-args %earlyoom-configuration-sample))
+
+(test-end "linux-services")