summaryrefslogtreecommitdiff
path: root/tests
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2014-12-27 23:22:08 +0100
committerLudovic Courtès <ludo@gnu.org>2014-12-27 23:22:49 +0100
commitaf07095516b56dcdd38bf1874da27de9c4c841f6 (patch)
tree41c1ca864f2eaeaf3a07dc0a31c60f2c1a0fe386 /tests
parent856ae5e6c71a1283a414d33e638051f95d3cce35 (diff)
downloadpatches-af07095516b56dcdd38bf1874da27de9c4c841f6.tar
patches-af07095516b56dcdd38bf1874da27de9c4c841f6.tar.gz
packages: Add 'file-type' field to 'search-path-specification'.
Fixes <http://bugs.gnu.org/18033>. * guix/packages.scm (<search-path-specification>): Rename 'directories' field to 'files'. Add 'file-type'. (search-path-specification->sexp): Honor 'file-type'. * gnu/packages/autotools.scm, gnu/packages/bootstrap.scm, gnu/packages/cross-base.scm, gnu/packages/games.scm, gnu/packages/gcc.scm, gnu/packages/glib.scm, gnu/packages/guile.scm, gnu/packages/man.scm, gnu/packages/perl.scm, gnu/packages/pkg-config.scm, gnu/packages/python.scm, gnu/packages/ruby.scm, gnu/packages/xfce.scm: Change 'directories' to 'files'. * tests/packages.scm ("search paths"): Change 'directories' field to 'files'. * guix/scripts/environment.scm (for-each-search-path): Likewise.
Diffstat (limited to 'tests')
-rw-r--r--tests/packages.scm4
1 files changed, 2 insertions, 2 deletions
diff --git a/tests/packages.scm b/tests/packages.scm
index 98fa9b5698..b2f09c6d6c 100644
--- a/tests/packages.scm
+++ b/tests/packages.scm
@@ -335,10 +335,10 @@
search-paths)))))))
(x (list (search-path-specification
(variable "GUILE_LOAD_PATH")
- (directories '("share/guile/site/2.0")))
+ (files '("share/guile/site/2.0")))
(search-path-specification
(variable "GUILE_LOAD_COMPILED_PATH")
- (directories '("share/guile/site/2.0")))))
+ (files '("share/guile/site/2.0")))))
(a (package (inherit (dummy-package "guile"))
(build-system s)
(native-search-paths x)))