summaryrefslogtreecommitdiff
path: root/tests
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2020-04-30 23:47:49 +0200
committerMarius Bakke <mbakke@fastmail.com>2020-04-30 23:47:49 +0200
commit8bf8cd9b85c85be387565f6c8ca9f6c72196fb8e (patch)
tree6fa0f8ba32b83a996625bc188903ccebfb7e7c2c /tests
parent5d9e2187929ed7e8d46ec3cb3174fd78c1846360 (diff)
parent229f4fa9522fb56b014ee9c0d8111e8fb6da764d (diff)
downloadpatches-8bf8cd9b85c85be387565f6c8ca9f6c72196fb8e.tar
patches-8bf8cd9b85c85be387565f6c8ca9f6c72196fb8e.tar.gz
Merge branch 'master' into core-updates
Conflicts: gnu/local.mk gnu/packages/backup.scm gnu/packages/emacs-xyz.scm gnu/packages/guile.scm gnu/packages/lisp.scm gnu/packages/openldap.scm gnu/packages/package-management.scm gnu/packages/web.scm gnu/packages/xorg.scm
Diffstat (limited to 'tests')
-rw-r--r--tests/crate.scm23
-rw-r--r--tests/gem.scm2
-rw-r--r--tests/profiles.scm13
-rw-r--r--tests/pypi.scm7
4 files changed, 29 insertions, 16 deletions
diff --git a/tests/crate.scm b/tests/crate.scm
index aa51faebf9..61a04f986b 100644
--- a/tests/crate.scm
+++ b/tests/crate.scm
@@ -55,7 +55,7 @@
\"dependencies\": [
{
\"crate_id\": \"bar\",
- \"kind\": \"normal\",
+ \"kind\": \"normal\"
}
]
}")
@@ -87,20 +87,20 @@
\"dependencies\": [
{
\"crate_id\": \"intermediate-1\",
- \"kind\": \"normal\",
+ \"kind\": \"normal\"
},
{
\"crate_id\": \"intermediate-2\",
- \"kind\": \"normal\",
+ \"kind\": \"normal\"
}
{
\"crate_id\": \"leaf-alice\",
- \"kind\": \"normal\",
+ \"kind\": \"normal\"
},
{
\"crate_id\": \"leaf-bob\",
- \"kind\": \"normal\",
- },
+ \"kind\": \"normal\"
+ }
]
}")
@@ -131,15 +131,15 @@
\"dependencies\": [
{
\"crate_id\": \"intermediate-2\",
- \"kind\": \"normal\",
+ \"kind\": \"normal\"
},
{
\"crate_id\": \"leaf-alice\",
- \"kind\": \"normal\",
+ \"kind\": \"normal\"
},
{
\"crate_id\": \"leaf-bob\",
- \"kind\": \"normal\",
+ \"kind\": \"normal\"
}
]
}")
@@ -171,8 +171,8 @@
\"dependencies\": [
{
\"crate_id\": \"leaf-bob\",
- \"kind\": \"normal\",
- },
+ \"kind\": \"normal\"
+ }
]
}")
@@ -233,6 +233,7 @@
(define test-source-hash
"")
+
(test-begin "crate")
(test-equal "guix-package->crate-name"
diff --git a/tests/gem.scm b/tests/gem.scm
index 455fc15189..751bba656f 100644
--- a/tests/gem.scm
+++ b/tests/gem.scm
@@ -52,7 +52,7 @@
\"homepage_uri\": \"https://example.com\",
\"dependencies\": {
\"runtime\": [
- { \"name\": \"bundler\" },
+ { \"name\": \"bundler\" }
]
},
\"licenses\": null
diff --git a/tests/profiles.scm b/tests/profiles.scm
index 21c912a532..055924ba3e 100644
--- a/tests/profiles.scm
+++ b/tests/profiles.scm
@@ -1,5 +1,5 @@
;;; GNU Guix --- Functional package management for GNU
-;;; Copyright © 2013, 2014, 2015, 2016, 2017, 2018, 2019 Ludovic Courtès <ludo@gnu.org>
+;;; Copyright © 2013, 2014, 2015, 2016, 2017, 2018, 2019, 2020 Ludovic Courtès <ludo@gnu.org>
;;; Copyright © 2014 Alex Kost <alezost@gmail.com>
;;;
;;; This file is part of GNU Guix.
@@ -223,6 +223,17 @@
(string=? (dirname (readlink bindir))
(derivation->output-path guile))))))
+(test-assertm "<profile>"
+ (mlet* %store-monad
+ ((entry -> (package->manifest-entry %bootstrap-guile))
+ (profile -> (profile (hooks '()) (locales? #f)
+ (content (manifest (list entry)))))
+ (drv (lower-object profile))
+ (profile -> (derivation->output-path drv))
+ (bindir -> (string-append profile "/bin"))
+ (_ (built-derivations (list drv))))
+ (return (file-exists? (string-append bindir "/guile")))))
+
(test-assertm "profile-derivation relative symlinks, one entry"
(mlet* %store-monad
((entry -> (package->manifest-entry %bootstrap-guile))
diff --git a/tests/pypi.scm b/tests/pypi.scm
index 19af6e61fb..6788c8db3e 100644
--- a/tests/pypi.scm
+++ b/tests/pypi.scm
@@ -46,13 +46,13 @@
\"1.0.0\": [
{
\"url\": \"https://example.com/foo-1.0.0.egg\",
- \"packagetype\": \"bdist_egg\",
+ \"packagetype\": \"bdist_egg\"
}, {
\"url\": \"https://example.com/foo-1.0.0.tar.gz\",
- \"packagetype\": \"sdist\",
+ \"packagetype\": \"sdist\"
}, {
\"url\": \"https://example.com/foo-1.0.0-py2.py3-none-any.whl\",
- \"packagetype\": \"bdist_wheel\",
+ \"packagetype\": \"bdist_wheel\"
}
]
}
@@ -120,6 +120,7 @@ Provides-Extra: testing
Requires-Dist: pytest (>=3.1.0); extra == 'testing'
")
+
(test-begin "pypi")
(test-equal "guix-package->pypi-name, old URL style"