summaryrefslogtreecommitdiff
path: root/tests/syscalls.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2014-05-10 21:49:11 +0200
committerLudovic Courtès <ludo@gnu.org>2014-05-10 22:55:34 +0200
commit29fa45f45d3192ad0f8d2c46523d7a7d6422c9e9 (patch)
tree6da920c74bc4ab967faad05d33b71d9c2d34d8c6 /tests/syscalls.scm
parent02139eb9b2bdbe1b342a0550dd8725a764716c28 (diff)
downloadpatches-29fa45f45d3192ad0f8d2c46523d7a7d6422c9e9.tar
patches-29fa45f45d3192ad0f8d2c46523d7a7d6422c9e9.tar.gz
Add (guix build syscalls).
* guix/build/syscalls.scm, tests/syscalls.scm: New files. * Makefile.am (MODULES): Add guix/build/syscalls.scm. (SCM_TESTS): Add tests/syscalls.scm. * guix/utils.scm (%libc-errno-pointer, errno): Remove; take from (guix build syscalls).
Diffstat (limited to 'tests/syscalls.scm')
-rw-r--r--tests/syscalls.scm47
1 files changed, 47 insertions, 0 deletions
diff --git a/tests/syscalls.scm b/tests/syscalls.scm
new file mode 100644
index 0000000000..5243ac9a34
--- /dev/null
+++ b/tests/syscalls.scm
@@ -0,0 +1,47 @@
+;;; GNU Guix --- Functional package management for GNU
+;;; Copyright © 2014 Ludovic Courtès <ludo@gnu.org>
+;;;
+;;; This file is part of GNU Guix.
+;;;
+;;; GNU Guix is free software; you can redistribute it and/or modify it
+;;; under the terms of the GNU General Public License as published by
+;;; the Free Software Foundation; either version 3 of the License, or (at
+;;; your option) any later version.
+;;;
+;;; GNU Guix is distributed in the hope that it will be useful, but
+;;; WITHOUT ANY WARRANTY; without even the implied warranty of
+;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+;;; GNU General Public License for more details.
+;;;
+;;; You should have received a copy of the GNU General Public License
+;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
+
+(define-module (test-syscalls)
+ #:use-module (guix build syscalls)
+ #:use-module (srfi srfi-64))
+
+;; Test the (guix build syscalls) module, although there's not much that can
+;; actually be tested without being root.
+
+(test-begin "syscalls")
+
+(test-equal "mount, ENOENT"
+ ENOENT
+ (catch 'system-error
+ (lambda ()
+ (mount "/dev/null" "/does-not-exist" "ext2")
+ #f)
+ (compose system-error-errno list)))
+
+(test-equal "umount, ENOENT"
+ ENOENT
+ (catch 'system-error
+ (lambda ()
+ (umount "/does-not-exist")
+ #f)
+ (compose system-error-errno list)))
+
+(test-end)
+
+
+(exit (= (test-runner-fail-count (test-runner-current)) 0))