summaryrefslogtreecommitdiff
path: root/tests/store.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2014-08-23 19:18:01 +0200
committerLudovic Courtès <ludo@gnu.org>2014-08-23 22:33:04 +0200
commitc1bc358f293b97c9575f6195c3e7a119b05199ce (patch)
tree2e75aafa414fe066598ca4f9f1b1b7eb4250c238 /tests/store.scm
parent90a063f4ca4e538df669103a7ffdd211e45f63d6 (diff)
downloadpatches-c1bc358f293b97c9575f6195c3e7a119b05199ce.tar
patches-c1bc358f293b97c9575f6195c3e7a119b05199ce.tar.gz
Factorize test suite support in (guix tests).
* guix/tests.scm: New file. * Makefile.am (noinst_DATA): New variable. (GOBJECTS): Add guix/tests.go. * tests/builders.scm (%store): Use 'open-connection-for-tests' from (guix tests). * tests/derivations.scm: Likewise. * tests/monads.scm: Likewise. * tests/packages.scm: Likewise. * tests/profiles.scm: Likewise. * tests/union.scm: Likewise. * tests/gexp.scm: Likewise. (guile-for-build): Remove. Use (%guile-for-build) instead. * tests/nar.scm (make-random-bytevector, %seed, random-text): Remove. (populate-file): Change 'make-random-bytevector' to 'random-bytevector'. Use (guix tests). * tests/store.scm (%seed, random-text): Remove. Use (guix tests).
Diffstat (limited to 'tests/store.scm')
-rw-r--r--tests/store.scm14
1 files changed, 2 insertions, 12 deletions
diff --git a/tests/store.scm b/tests/store.scm
index b0f609f818..ba15524be4 100644
--- a/tests/store.scm
+++ b/tests/store.scm
@@ -16,8 +16,8 @@
;;; You should have received a copy of the GNU General Public License
;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
-
(define-module (test-store)
+ #:use-module (guix tests)
#:use-module (guix store)
#:use-module (guix utils)
#:use-module (guix hash)
@@ -40,17 +40,7 @@
;; Test the (guix store) module.
(define %store
- (false-if-exception (open-connection)))
-
-(when %store
- ;; Make sure we build everything by ourselves.
- (set-build-options %store #:use-substitutes? #f))
-
-(define %seed
- (seed->random-state (logxor (getpid) (car (gettimeofday)))))
-
-(define (random-text)
- (number->string (random (expt 2 256) %seed) 16))
+ (open-connection-for-tests))
(test-begin "store")