summaryrefslogtreecommitdiff
path: root/tests/snix.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2015-10-06 22:33:03 +0200
committerLudovic Courtès <ludo@gnu.org>2015-10-06 23:51:04 +0200
commitf073e52382d2ddcc638de73533bbf798f600d78a (patch)
treee51183c70aee2452d20c965feb515689da2dcb28 /tests/snix.scm
parentdd01fecd23a4ded46b99a51dc08ac5d964dbcd53 (diff)
downloadpatches-f073e52382d2ddcc638de73533bbf798f600d78a.tar
patches-f073e52382d2ddcc638de73533bbf798f600d78a.tar.gz
utils: Remove Nixpkgs helpers.
* guix/config.scm.in (%nixpkgs): Remove. * guix/utils.scm (%nixpkgs-directory, nixpkgs-derivation, nixpkgs-derivation*): Remove. * test-env.in: Export 'NIXPKGS'. * tests/derivations.scm (%coreutils): Remove use of 'nixpkgs-derivation'. * tests/snix.scm (%nixpkgs-directory): New variable. Adjust users accordingly.
Diffstat (limited to 'tests/snix.scm')
-rw-r--r--tests/snix.scm12
1 files changed, 7 insertions, 5 deletions
diff --git a/tests/snix.scm b/tests/snix.scm
index 2318780d3d..a66b2c7b60 100644
--- a/tests/snix.scm
+++ b/tests/snix.scm
@@ -1,5 +1,5 @@
;;; GNU Guix --- Functional package management for GNU
-;;; Copyright © 2012, 2013 Ludovic Courtès <ludo@gnu.org>
+;;; Copyright © 2012, 2013, 2015 Ludovic Courtès <ludo@gnu.org>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -18,11 +18,13 @@
(define-module (test-snix)
#:use-module (guix import snix)
- #:use-module ((guix utils) #:select (%nixpkgs-directory))
#:use-module (srfi srfi-1)
#:use-module (srfi srfi-64)
#:use-module (ice-9 match))
+(define %nixpkgs-directory
+ (getenv "NIXPKGS"))
+
(define factorize-uri
(@@ (guix import snix) factorize-uri))
@@ -43,14 +45,14 @@
("http://example.com/2.8/foo-2.8.tgz" "2.8"
-> ("http://example.com/" version "/foo-" version ".tgz")))))
-(test-skip (if (and (%nixpkgs-directory)
- (file-exists? (string-append (%nixpkgs-directory)
+(test-skip (if (and %nixpkgs-directory
+ (file-exists? (string-append %nixpkgs-directory
"/default.nix")))
0
1))
(test-assert "nixpkgs->guix-package"
- (match (nixpkgs->guix-package (%nixpkgs-directory) "guile")
+ (match (nixpkgs->guix-package %nixpkgs-directory "guile")
(('package
('name "guile")
('version (? string?))