aboutsummaryrefslogtreecommitdiff
path: root/tests/search-paths.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2019-10-08 11:23:22 +0200
committerLudovic Courtès <ludo@gnu.org>2019-10-08 11:37:07 +0200
commitcf3d1763ede1a329c2bc932c84591ab594bb6c96 (patch)
tree665f92418f8671474de3815241fb657384463c94 /tests/search-paths.scm
parentd57660c54907cc6fba8b0adf6295fd2311ada6cf (diff)
parent2fa55c72476c73211cbb2d6b29c05a1ad58a6cf9 (diff)
downloadpatches-cf3d1763ede1a329c2bc932c84591ab594bb6c96.tar
patches-cf3d1763ede1a329c2bc932c84591ab594bb6c96.tar.gz
Merge branch 'core-updates'
Diffstat (limited to 'tests/search-paths.scm')
-rw-r--r--tests/search-paths.scm8
1 files changed, 4 insertions, 4 deletions
diff --git a/tests/search-paths.scm b/tests/search-paths.scm
index 8dad424415..767a80b76c 100644
--- a/tests/search-paths.scm
+++ b/tests/search-paths.scm
@@ -1,5 +1,5 @@
;;; GNU Guix --- Functional package management for GNU
-;;; Copyright © 2017 Ludovic Courtès <ludo@gnu.org>
+;;; Copyright © 2017, 2019 Ludovic Courtès <ludo@gnu.org>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -29,17 +29,17 @@
(test-equal "evaluate-search-paths, separator is #f"
(string-append %top-srcdir
- "/gnu/packages/bootstrap/aarch64-linux")
+ "/gnu/packages/aux-files/linux-libre")
;; The following search path spec should evaluate to a single item: the
;; first directory that matches the "-linux$" pattern in
;; gnu/packages/bootstrap.
(let ((spec (search-path-specification
(variable "CHBOUIB")
- (files '("gnu/packages/bootstrap"))
+ (files '("gnu/packages/aux-files"))
(file-type 'directory)
(separator #f)
- (file-pattern "-linux$"))))
+ (file-pattern "^linux"))))
(match (evaluate-search-paths (list spec)
(list %top-srcdir))
(((spec* . value))