summaryrefslogtreecommitdiff
path: root/tests/guix-package-aliases.sh
diff options
context:
space:
mode:
authorzimoun <zimon.toutoune@gmail.com>2019-09-19 19:24:42 +0200
committerLudovic Courtès <ludo@gnu.org>2019-09-21 16:48:36 +0200
commitaeb51370da7c854e8167066df9b138e15d7363e6 (patch)
treec16cf197f6680b90de1fc2da2ffcde2bdd6e1721 /tests/guix-package-aliases.sh
parentc1bbef6920b1eb7e212b5e11d0385d477a53fbfb (diff)
downloadpatches-aeb51370da7c854e8167066df9b138e15d7363e6.tar
patches-aeb51370da7c854e8167066df9b138e15d7363e6.tar.gz
guix package: Add 'guix show' alias.
* guix/scripts/show.scm: New file. * Makefile.am (MODULES): Add it. * po/guix/POTFILES.in: Add it. * tests/guix-package-aliases.sh: Add test. * doc/guix.texi (Invoking guix package): Document it and use it in a example. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'tests/guix-package-aliases.sh')
-rw-r--r--tests/guix-package-aliases.sh4
1 files changed, 4 insertions, 0 deletions
diff --git a/tests/guix-package-aliases.sh b/tests/guix-package-aliases.sh
index 5c68664093..9c038b99a5 100644
--- a/tests/guix-package-aliases.sh
+++ b/tests/guix-package-aliases.sh
@@ -58,3 +58,7 @@ if guix remove -i guile-bootstrap -p "$profile" --bootstrap
then false; else true; fi
guix search '\<board\>' game | grep '^name: gnubg'
+
+guix show --version
+guix show guile
+guix show python@3 | grep "^name: python"