aboutsummaryrefslogtreecommitdiff
path: root/tests/guix-gc.sh
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2013-03-04 23:27:24 +0100
committerLudovic Courtès <ludo@gnu.org>2013-03-04 23:27:24 +0100
commit81eec00cb221231123b74d14245ef7caa9d89ff6 (patch)
tree3beeb77c5535038dc75db843dd88a1775fb541bb /tests/guix-gc.sh
parent8689a1908a8353b80ed1fcbb81feddc5eb799f24 (diff)
parent2a1e82bb5c2ae28b0018aa765cff6733136b3f70 (diff)
downloadpatches-81eec00cb221231123b74d14245ef7caa9d89ff6.tar
patches-81eec00cb221231123b74d14245ef7caa9d89ff6.tar.gz
Merge branch 'master' into core-updates
Conflicts: Makefile.am guix/scripts/gc.scm guix/scripts/package.scm guix/ui.scm tests/guix-package.sh
Diffstat (limited to 'tests/guix-gc.sh')
-rw-r--r--tests/guix-gc.sh12
1 files changed, 12 insertions, 0 deletions
diff --git a/tests/guix-gc.sh b/tests/guix-gc.sh
index a90d085ab2..eac9d82e89 100644
--- a/tests/guix-gc.sh
+++ b/tests/guix-gc.sh
@@ -25,6 +25,18 @@ guix gc --version
trap "rm -f guix-gc-root" EXIT
rm -f guix-gc-root
+# Check the references of a .drv.
+drv="`guix build guile-bootstrap -d`"
+out="`guix build guile-bootstrap`"
+test -f "$drv" && test -d "$out"
+
+guix gc --references "$drv" | grep -e -bash
+guix gc --references "$out"
+guix gc --references "$out/bin/guile"
+
+if guix gc --references /dev/null;
+then false; else true; fi
+
# Add then reclaim a .drv file.
drv="`guix build idutils -d`"
test -f "$drv"