summaryrefslogtreecommitdiff
path: root/tests/guix-download.sh
diff options
context:
space:
mode:
authorMark H Weaver <mhw@netris.org>2013-02-14 04:15:25 -0500
committerMark H Weaver <mhw@netris.org>2013-02-16 22:17:37 -0500
commite49951eb3e1e1a8e7bad6d7471483e70b0865352 (patch)
tree7924fec33724f1de6a1cdd0757c7ebe38c7bee6b /tests/guix-download.sh
parent040860152e63bbafb2eb3e93619e18d107c96b55 (diff)
downloadpatches-e49951eb3e1e1a8e7bad6d7471483e70b0865352.tar
patches-e49951eb3e1e1a8e7bad6d7471483e70b0865352.tar.gz
Replace individual scripts with master 'guix' script.
* scripts/guix.in: New script. * Makefile.am (bin_SCRIPTS): Add 'scripts/guix'. Remove 'guix-build', 'guix-download', 'guix-import', 'guix-package', and 'guix-gc'. (MODULES): Add 'guix/scripts/build.scm', 'guix/scripts/download.scm', 'guix/scripts/import.scm', 'guix/scripts/package.scm', and 'guix/scripts/gc.scm'. * configure.ac (AC_CONFIG_FILES): Add 'scripts/guix'. Remove 'guix-build', 'guix-download', 'guix-import', 'guix-package', and 'guix-gc'. * guix-build.in, guix-download.in, guix-gc.in, guix-import.in, guix-package.in: Remove shell script boilerplate. Move to guix-COMMAND.in to guix/scripts/COMMAND.scm. Rename module from (guix-COMMAND) to (guix scripts COMMAND). Change "guix-COMMAND" to "guix COMMAND" in usage help string. * pre-inst-env.in: Add "@abs_top_builddir@/scripts" to the front of $PATH. Export $GUIX_UNINSTALLED. * tests/guix-build.sh, tests/guix-daemon.sh, tests/guix-download.sh, tests/guix-gc.sh, tests/guix-package.sh: Use "guix COMMAND" instead of "guix-COMMAND". * doc/guix.texi: Replace all occurrences of "guix-COMMAND" with "guix COMMAND". * po/POTFILES.in: Update.
Diffstat (limited to 'tests/guix-download.sh')
-rw-r--r--tests/guix-download.sh12
1 files changed, 6 insertions, 6 deletions
diff --git a/tests/guix-download.sh b/tests/guix-download.sh
index f0ea731430..7af6f181f6 100644
--- a/tests/guix-download.sh
+++ b/tests/guix-download.sh
@@ -17,20 +17,20 @@
# along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
#
-# Test the `guix-download' command-line utility.
+# Test the `guix download' command-line utility.
#
-guix-download --version
+guix download --version
# Make sure it fails here.
-if guix-download http://does.not/exist
+if guix download http://does.not/exist
then false; else true; fi
-if guix-download unknown://some/where;
+if guix download unknown://some/where;
then false; else true; fi
-if guix-download not/a/uri;
+if guix download not/a/uri;
then false; else true; fi
# This one should succeed.
-guix-download "file://$abs_top_srcdir/README"
+guix download "file://$abs_top_srcdir/README"