summaryrefslogtreecommitdiff
path: root/tests/guix-download.sh
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2012-11-13 22:57:50 +0100
committerLudovic Courtès <ludo@gnu.org>2012-11-13 22:58:43 +0100
commit352ec143de32e751286590ff51c40f5a32c7fa87 (patch)
treedd52b23ac37be4fb6023810c7485894c776a5cbe /tests/guix-download.sh
parentecdb81e159a29c92351bc51c3556a760074f7473 (diff)
downloadpatches-352ec143de32e751286590ff51c40f5a32c7fa87.tar
patches-352ec143de32e751286590ff51c40f5a32c7fa87.tar.gz
guix-download: Add support for file:// URIs.
* guix-download.in (fetch-and-store): New procedure. (guix-download): Use it to compute PATH. Call `add-to-store' when a `file' URI scheme is used. * Makefile.am (AM_TESTS_ENVIRONMENT): New variable. * tests/guix-download.sh: Add test.
Diffstat (limited to 'tests/guix-download.sh')
-rw-r--r--tests/guix-download.sh3
1 files changed, 3 insertions, 0 deletions
diff --git a/tests/guix-download.sh b/tests/guix-download.sh
index fc7b35d1b3..e756600404 100644
--- a/tests/guix-download.sh
+++ b/tests/guix-download.sh
@@ -31,3 +31,6 @@ then false; else true; fi
if guix-download not/a/uri;
then false; else true; fi
+
+# This one should succeed.
+guix-download "file://$abs_top_srcdir/README"