summaryrefslogtreecommitdiff
path: root/tests/gremlin.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2015-03-31 22:10:08 +0200
committerLudovic Courtès <ludo@gnu.org>2015-03-31 22:23:57 +0200
commit15aa2c38429a5785ed08519c88ff89a0b7027f0f (patch)
tree7f27314896deaed8d54ff1c518f60825d165c735 /tests/gremlin.scm
parent4e7b6b4838318ca127ae588a7a28c8608b0c8721 (diff)
downloadpatches-15aa2c38429a5785ed08519c88ff89a0b7027f0f.tar
patches-15aa2c38429a5785ed08519c88ff89a0b7027f0f.tar.gz
Add (guix build gremlin).
* guix/build/gremlin.scm, tests/gremlin.scm: New files. * Makefile.am (MODULES): Add guix/build/gremlin.scm. (SCM_TESTS): Add tests/gremlin.scm.
Diffstat (limited to 'tests/gremlin.scm')
-rw-r--r--tests/gremlin.scm57
1 files changed, 57 insertions, 0 deletions
diff --git a/tests/gremlin.scm b/tests/gremlin.scm
new file mode 100644
index 0000000000..225a72ff9f
--- /dev/null
+++ b/tests/gremlin.scm
@@ -0,0 +1,57 @@
+;;; GNU Guix --- Functional package management for GNU
+;;; Copyright © 2015 Ludovic Courtès <ludo@gnu.org>
+;;;
+;;; This file is part of GNU Guix.
+;;;
+;;; GNU Guix is free software; you can redistribute it and/or modify it
+;;; under the terms of the GNU General Public License as published by
+;;; the Free Software Foundation; either version 3 of the License, or (at
+;;; your option) any later version.
+;;;
+;;; GNU Guix is distributed in the hope that it will be useful, but
+;;; WITHOUT ANY WARRANTY; without even the implied warranty of
+;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+;;; GNU General Public License for more details.
+;;;
+;;; You should have received a copy of the GNU General Public License
+;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
+
+(define-module (test-gremlin)
+ #:use-module (guix elf)
+ #:use-module (guix build utils)
+ #:use-module (guix build gremlin)
+ #:use-module (srfi srfi-1)
+ #:use-module (srfi srfi-64)
+ #:use-module (rnrs io ports)
+ #:use-module (ice-9 match))
+
+(define %guile-executable
+ (match (command-line)
+ ((program . _)
+ (and (file-exists? program) (elf-file? program)
+ program))
+ (_
+ #f)))
+
+(define read-elf
+ (compose parse-elf get-bytevector-all))
+
+
+(test-begin "gremlin")
+
+(unless %guile-executable (test-skip 1))
+(test-assert "elf-dynamic-info-needed, executable"
+ (let* ((elf (call-with-input-file %guile-executable read-elf))
+ (dyninfo (elf-dynamic-info elf)))
+ (or (not dyninfo) ;static executable
+ (lset<= string=?
+ (list (string-append "libguile-" (effective-version))
+ "libgc" "libunistring" "libffi")
+ (map (lambda (lib)
+ (string-take lib (string-contains lib ".so")))
+ (elf-dynamic-info-needed dyninfo))))))
+
+(test-end "gremlin")
+
+
+(exit (= (test-runner-fail-count (test-runner-current)) 0))