summaryrefslogtreecommitdiff
path: root/tests/graph.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2015-11-21 13:12:02 +0100
committerLudovic Courtès <ludo@gnu.org>2015-11-21 16:26:43 +0100
commit8fb583714f78d1b283523ef7edbb6e098946182f (patch)
tree13db949dd4869d2c8b41a3a1ce0a28f9bacbb860 /tests/graph.scm
parent1b933e62dcc8521e383a78e5d7952a194e47a4ec (diff)
downloadpatches-8fb583714f78d1b283523ef7edbb6e098946182f.tar
patches-8fb583714f78d1b283523ef7edbb6e098946182f.tar.gz
Add (guix graph).
* guix/scripts/graph.scm (<node-type>, <graph-backend>, emit-prologue) (emit-epilogue, emit-node, emit-edge, %graphviz-backend, export-graph): Move to... * guix/graph.scm: ... here. New file. * guix/scripts/system.scm, tests/graph.scm: Use it. * Makefile.am (MODULES): Add it.
Diffstat (limited to 'tests/graph.scm')
-rw-r--r--tests/graph.scm1
1 files changed, 1 insertions, 0 deletions
diff --git a/tests/graph.scm b/tests/graph.scm
index f454b06351..ed5849f4da 100644
--- a/tests/graph.scm
+++ b/tests/graph.scm
@@ -18,6 +18,7 @@
(define-module (test-graph)
#:use-module (guix tests)
+ #:use-module (guix graph)
#:use-module (guix scripts graph)
#:use-module (guix packages)
#:use-module (guix derivations)