summaryrefslogtreecommitdiff
path: root/tests/builders.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2012-11-13 00:22:44 +0100
committerLudovic Courtès <ludo@gnu.org>2012-11-13 00:23:39 +0100
commit87f5d36630db13fee1f2c0563505dc0938f3787e (patch)
tree9cbbbd3d3c47b647ff7b3131cf8271586e5167a6 /tests/builders.scm
parent62cab99c3297a066f466780bb4d83a4f142538c7 (diff)
downloadpatches-87f5d36630db13fee1f2c0563505dc0938f3787e.tar
patches-87f5d36630db13fee1f2c0563505dc0938f3787e.tar.gz
Remove (guix http) and (guix ftp).
* guix/ftp.scm, guix/http.scm, guix/build/ftp.scm, guix/build/http.scm: Remove. * Makefile.am (MODULES): Likewise. * tests/builders.scm, distro/packages/base.scm, distro/packages/bash.scm, distro/packages/bdw-gc.scm, distro/packages/compression.scm, distro/packages/gawk.scm, distro/packages/gnupg.scm, distro/packages/gperf.scm, distro/packages/guile.scm, distro/packages/libffi.scm, distro/packages/libsigsegv.scm, distro/packages/libtool.scm, distro/packages/libunistring.scm, distro/packages/lout.scm, distro/packages/m4.scm, distro/packages/multiprecision.scm, distro/packages/ncurses.scm, distro/packages/perl.scm, distro/packages/pkg-config.scm, distro/packages/pth.scm, distro/packages/readline.scm, distro/packages/recutils.scm: Use `url-fetch' instead of `http-fetch' and `ftp-fetch'. * distro/packages/bootstrap.scm: Likewise (bootstrap-origin): Remove references to `http-fetch' and `ftp-fetch'. * guix.scm (%public-modules): Remove `http' and `ftp'; add `download'.
Diffstat (limited to 'tests/builders.scm')
-rw-r--r--tests/builders.scm13
1 files changed, 1 insertions, 12 deletions
diff --git a/tests/builders.scm b/tests/builders.scm
index 9cc86ef1c2..d2691c521f 100644
--- a/tests/builders.scm
+++ b/tests/builders.scm
@@ -18,7 +18,6 @@
(define-module (test-builders)
- #:use-module (guix http)
#:use-module (guix download)
#:use-module (guix build-system)
#:use-module (guix build-system gnu)
@@ -54,16 +53,6 @@
(test-begin "builders")
-(test-assert "http-fetch"
- (let* ((url "http://ftp.gnu.org/gnu/hello/hello-2.8.tar.gz")
- (hash (nix-base32-string->bytevector
- "0wqd8sjmxfskrflaxywc7gqw7sfawrfvdxd9skxawzfgyy0pzdz6"))
- (drv-path (http-fetch %store url 'sha256 hash))
- (out-path (derivation-path->output-path drv-path)))
- (and (build-derivations %store (list drv-path))
- (file-exists? out-path)
- (valid-path? %store out-path))))
-
(test-assert "url-fetch"
(let* ((url '("http://ftp.gnu.org/gnu/hello/hello-2.8.tar.gz"
"ftp://ftp.gnu.org/gnu/hello/hello-2.8.tar.gz"))
@@ -83,7 +72,7 @@
(let* ((url "http://ftp.gnu.org/gnu/hello/hello-2.8.tar.gz")
(hash (nix-base32-string->bytevector
"0wqd8sjmxfskrflaxywc7gqw7sfawrfvdxd9skxawzfgyy0pzdz6"))
- (tarball (http-fetch %store url 'sha256 hash))
+ (tarball (url-fetch %store url 'sha256 hash))
(build (gnu-build %store "hello-2.8" tarball
%bootstrap-inputs
#:implicit-inputs? #f