summaryrefslogtreecommitdiff
path: root/tests/build-utils.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2012-07-01 17:32:03 +0200
committerLudovic Courtès <ludo@gnu.org>2012-07-05 00:13:30 +0200
commitb0e0d0e99fab04fc374061adc7386b0f3f4b18c5 (patch)
tree1cfe48df8bf8e602ae6a1987b54d2f9f18d53f7c /tests/build-utils.scm
parentc9d01150c04e92770f72683bdfabf4ac939985d3 (diff)
downloadpatches-b0e0d0e99fab04fc374061adc7386b0f3f4b18c5.tar
patches-b0e0d0e99fab04fc374061adc7386b0f3f4b18c5.tar.gz
Add builder-side utilities for phases, stream editing, & co.
* guix/build/utils.scm (with-directory-excursion): New macro. (alist-cons-before, alist-cons-after, alist-replace): New procedures. (substitute): New procedure. * tests/build-utils.scm: New file. * Makefile.am (TESTS): Add `tests/build-utils.scm'.
Diffstat (limited to 'tests/build-utils.scm')
-rw-r--r--tests/build-utils.scm58
1 files changed, 58 insertions, 0 deletions
diff --git a/tests/build-utils.scm b/tests/build-utils.scm
new file mode 100644
index 0000000000..4d86037708
--- /dev/null
+++ b/tests/build-utils.scm
@@ -0,0 +1,58 @@
+;;; Guix --- Nix package management from Guile. -*- coding: utf-8 -*-
+;;; Copyright (C) 2012 Ludovic Courtès <ludo@gnu.org>
+;;;
+;;; This file is part of Guix.
+;;;
+;;; Guix is free software; you can redistribute it and/or modify it
+;;; under the terms of the GNU General Public License as published by
+;;; the Free Software Foundation; either version 3 of the License, or (at
+;;; your option) any later version.
+;;;
+;;; Guix is distributed in the hope that it will be useful, but
+;;; WITHOUT ANY WARRANTY; without even the implied warranty of
+;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+;;; GNU General Public License for more details.
+;;;
+;;; You should have received a copy of the GNU General Public License
+;;; along with Guix. If not, see <http://www.gnu.org/licenses/>.
+
+
+(define-module (test-build-utils)
+ #:use-module (guix build utils)
+ #:use-module (srfi srfi-64))
+
+(test-begin "build-utils")
+
+(test-equal "alist-cons-before"
+ '((a . 1) (x . 42) (b . 2) (c . 3))
+ (alist-cons-before 'b 'x 42 '((a . 1) (b . 2) (c . 3))))
+
+(test-equal "alist-cons-before, reference not found"
+ '((a . 1) (b . 2) (c . 3) (x . 42))
+ (alist-cons-before 'z 'x 42 '((a . 1) (b . 2) (c . 3))))
+
+(test-equal "alist-cons-after"
+ '((a . 1) (b . 2) (x . 42) (c . 3))
+ (alist-cons-after 'b 'x 42 '((a . 1) (b . 2) (c . 3))))
+
+(test-equal "alist-cons-after, reference not found"
+ '((a . 1) (b . 2) (c . 3) (x . 42))
+ (alist-cons-after 'z 'x 42 '((a . 1) (b . 2) (c . 3))))
+
+(test-equal "alist-replace"
+ '((a . 1) (b . 77) (c . 3))
+ (alist-replace 'b 77 '((a . 1) (b . 2) (c . 3))))
+
+(test-assert "alist-replace, key not found"
+ (not (false-if-exception
+ (alist-replace 'z 77 '((a . 1) (b . 2) (c . 3))))))
+
+(test-end)
+
+
+(exit (= (test-runner-fail-count (test-runner-current)) 0))
+
+;;; Local Variables:
+;;; eval: (put 'test-assert 'scheme-indent-function 1)
+;;; eval: (put 'test-equal 'scheme-indent-function 1)
+;;; End: