summaryrefslogtreecommitdiff
path: root/tests/bournish.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2016-06-06 18:12:31 +0200
committerLudovic Courtès <ludo@gnu.org>2016-06-06 18:14:52 +0200
commitf82c58539e1f7b9b864e68ea2ab0c6a17c15fbb5 (patch)
treed6e8c1f22cc9ec41d9fb3628d3540688dde99c02 /tests/bournish.scm
parent8bebe00a76012a07e91930dcfd68058d4309ae99 (diff)
downloadpatches-f82c58539e1f7b9b864e68ea2ab0c6a17c15fbb5.tar
patches-f82c58539e1f7b9b864e68ea2ab0c6a17c15fbb5.tar.gz
bournish: Allow compilation of multiple expressions.
* guix/build/bournish.scm (%bournish-language): Add a joiner to SCHEME. Compile only to Scheme. * tests/bournish.scm: New file. * Makefile.am (SCM_TESTS): Add it.
Diffstat (limited to 'tests/bournish.scm')
-rw-r--r--tests/bournish.scm42
1 files changed, 42 insertions, 0 deletions
diff --git a/tests/bournish.scm b/tests/bournish.scm
new file mode 100644
index 0000000000..0f529ce42f
--- /dev/null
+++ b/tests/bournish.scm
@@ -0,0 +1,42 @@
+;;; GNU Guix --- Functional package management for GNU
+;;; Copyright © 2016 Ludovic Courtès <ludo@gnu.org>
+;;;
+;;; This file is part of GNU Guix.
+;;;
+;;; GNU Guix is free software; you can redistribute it and/or modify it
+;;; under the terms of the GNU General Public License as published by
+;;; the Free Software Foundation; either version 3 of the License, or (at
+;;; your option) any later version.
+;;;
+;;; GNU Guix is distributed in the hope that it will be useful, but
+;;; WITHOUT ANY WARRANTY; without even the implied warranty of
+;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+;;; GNU General Public License for more details.
+;;;
+;;; You should have received a copy of the GNU General Public License
+;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
+
+(define-module (test-bournish)
+ #:use-module (guix build bournish)
+ #:use-module (system base compile)
+ #:use-module (system base language)
+ #:use-module (srfi srfi-64))
+
+
+(test-begin "bournish")
+
+(test-equal "single statement"
+ '(chdir "/foo")
+ (read-and-compile (open-input-string "cd /foo")
+ #:from %bournish-language #:to 'scheme))
+
+(test-equal "multiple statements"
+ '(begin
+ (chdir "/foo")
+ (getcwd)
+ ((@@ (guix build bournish) ls-command-implementation)))
+ (read-and-compile (open-input-string "cd /foo\npwd\nls")
+ #:from %bournish-language #:to 'scheme))
+
+(test-end "bournish")
+