summaryrefslogtreecommitdiff
path: root/tests/base64.scm
diff options
context:
space:
mode:
authorNikita Karetnikov <nikita@karetnikov.org>2014-03-29 00:06:41 +0100
committerLudovic Courtès <ludo@gnu.org>2014-03-30 12:02:10 +0200
commite9c6c58418043f36862a798389f3a7f4253f74cc (patch)
treec356b60c18a2aa02284dc565f6671f95f86fe8fb /tests/base64.scm
parent24194b6b543427510766813fdce01cfb79d00651 (diff)
downloadpatches-e9c6c58418043f36862a798389f3a7f4253f74cc.tar
patches-e9c6c58418043f36862a798389f3a7f4253f74cc.tar.gz
substitute-binary: Support the Signature field of a narinfo file.
* guix/scripts/substitute-binary.scm (<narinfo>): Add the 'signature' and 'contents' fields. (narinfo-signature->canonical-sexp): New function. (narinfo-maker): Add the 'signature' argument and use it. (assert-valid-signature): New function. (read-narinfo): Support the Signature field. (write-narinfo): Use 'narinfo-contents'. (%allow-unauthenticated-substitutes?): New variable. * guix/base64.scm, tests/base64.scm, tests/substitute-binary.scm: New files. * Makefile.am (SCM_TESTS): Add tests/base64.scm and tests/substitute-binary.scm. (MODULES): Add guix/base64.scm. * test-env.in: Set 'GUIX_ALLOW_UNAUTHENTICATED_SUBSTITUTES'.
Diffstat (limited to 'tests/base64.scm')
-rw-r--r--tests/base64.scm59
1 files changed, 59 insertions, 0 deletions
diff --git a/tests/base64.scm b/tests/base64.scm
new file mode 100644
index 0000000000..99c02b531e
--- /dev/null
+++ b/tests/base64.scm
@@ -0,0 +1,59 @@
+;;; GNU Guix --- Functional package management for GNU
+;;; Copyright © 2014 Nikita Karetnikov <nikita@karetnikov.org>
+;;;
+;;; This file is part of GNU Guix.
+;;;
+;;; GNU Guix is free software; you can redistribute it and/or modify it
+;;; under the terms of the GNU General Public License as published by
+;;; the Free Software Foundation; either version 3 of the License, or (at
+;;; your option) any later version.
+;;;
+;;; GNU Guix is distributed in the hope that it will be useful, but
+;;; WITHOUT ANY WARRANTY; without even the implied warranty of
+;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+;;; GNU General Public License for more details.
+;;;
+;;; You should have received a copy of the GNU General Public License
+;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
+
+(define-module (test-base64)
+ #:use-module (guix base64)
+ #:use-module (rnrs bytevectors)
+ #:use-module (srfi srfi-64))
+
+(define (string->base64 str)
+ (base64-encode (string->utf8 str)))
+
+;;; Test vectors from <https://tools.ietf.org/rfc/rfc4648.txt>.
+
+(test-begin "base64")
+
+(test-equal "empty string"
+ (string->base64 "")
+ "")
+
+(test-equal "f"
+ (string->base64 "f")
+ "Zg==")
+
+(test-equal "fo"
+ (string->base64 "fo")
+ "Zm8=")
+
+(test-equal "foo"
+ (string->base64 "foo")
+ "Zm9v")
+
+(test-equal "foob"
+ (string->base64 "foob")
+ "Zm9vYg==")
+
+(test-equal "fooba"
+ (string->base64 "fooba")
+ "Zm9vYmE=")
+
+(test-equal "foobar"
+ (string->base64 "foobar")
+ "Zm9vYmFy")
+
+(test-end "base64") \ No newline at end of file