summaryrefslogtreecommitdiff
path: root/scripts
diff options
context:
space:
mode:
authorMathieu Lirzin <mthl@gnu.org>2018-01-17 17:14:24 +0100
committerLudovic Courtès <ludo@gnu.org>2018-01-23 10:13:16 +0100
commitcba386c1295b7054df22dfb4662b1b92f668e2c0 (patch)
tree76078a073f62240b582c39cc20f8c9625edb6380 /scripts
parent341afe2a36125b11c1bc08bdc8f63421edaba008 (diff)
downloadpatches-cba386c1295b7054df22dfb4662b1b92f668e2c0.tar
patches-cba386c1295b7054df22dfb4662b1b92f668e2c0.tar.gz
build: Expand ‘scripts/guix’ at Make time.
This moves the complexity of Autotools variable expansion outside of the application code. * scripts/guix.in (config-lookup): Delete. (maybe-augment-load-paths!, run-guix-main): Use fully expanded variables instead of calling ‘config-lookup’. * configure.ac: Don't use AC_CONFIG_FILES for ‘scripts/guix’. Use AC_PROG_SED. * Makefile.am (scripts/guix): New rule. (do_subst): New variable. (CLEANFILES, EXTRA_DIST): Adapt. Co-authored-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'scripts')
-rw-r--r--scripts/guix.in31
1 files changed, 6 insertions, 25 deletions
diff --git a/scripts/guix.in b/scripts/guix.in
index e20c274242..af50a782bb 100644
--- a/scripts/guix.in
+++ b/scripts/guix.in
@@ -3,6 +3,7 @@
!#
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2013 Mark H Weaver <mhw@netris.org>
+;;; Copyright © 2018 Mathieu Lirzin <mthl@gnu.org>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -22,35 +23,15 @@
;; IMPORTANT: We must avoid loading any modules from Guix here,
;; because we need to adjust the guile load paths first.
;; It's okay to import modules from core Guile though.
-(use-modules (ice-9 regex)
- (srfi srfi-26))
+(use-modules (srfi srfi-26))
(let ()
(define-syntax-rule (push! elt v) (set! v (cons elt v)))
- (define config-lookup
- (let ((config '(("prefix" . "@prefix@")
- ("exec_prefix" . "@exec_prefix@")
- ("datarootdir" . "@datarootdir@")
- ("guilemoduledir" . "@guilemoduledir@")
- ("guileobjectdir" . "@guileobjectdir@")
- ("localedir" . "@localedir@")))
- (var-ref-regexp (make-regexp "\\$\\{([a-z_]+)\\}")))
- (define (expand-var-ref match)
- (lookup (match:substring match 1)))
- (define (expand str)
- (regexp-substitute/global #f var-ref-regexp str
- 'pre expand-var-ref 'post))
- (define (lookup name)
- (expand (assoc-ref config name)))
- lookup))
-
(define (maybe-augment-load-paths!)
(unless (getenv "GUIX_UNINSTALLED")
- (let ((module-dir (config-lookup "guilemoduledir"))
- (object-dir (config-lookup "guileobjectdir")))
- (push! module-dir %load-path)
- (push! object-dir %load-compiled-path))
+ (push! "@guilemoduledir@" %load-path)
+ (push! "@guileobjectdir@" %load-compiled-path)
(let ((updates-dir (and=> (or (getenv "XDG_CONFIG_HOME")
(and=> (getenv "HOME")
(cut string-append <> "/.config")))
@@ -64,8 +45,8 @@
(define (run-guix-main)
(let ((guix-main (module-ref (resolve-interface '(guix ui))
'guix-main)))
- (bindtextdomain "guix" (config-lookup "localedir"))
- (bindtextdomain "guix-packages" (config-lookup "localedir"))
+ (bindtextdomain "guix" "@localedir@")
+ (bindtextdomain "guix-packages" "@localedir@")
(apply guix-main (command-line))))
(maybe-augment-load-paths!)