aboutsummaryrefslogtreecommitdiff
path: root/release.nix
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2012-12-13 22:14:25 +0100
committerLudovic Courtès <ludo@gnu.org>2012-12-13 22:14:25 +0100
commit1e9824513c570370638b1bfe33bf1dba1f12be4a (patch)
treecb7bd7f0bebd42dbeabf2c8f09ae1d5144ac969b /release.nix
parent70915c1a2ef72e7350b2a29d1d93e30643bce6f3 (diff)
parentb35c0f866c83288e64dcf5839d908705d416c317 (diff)
downloadpatches-1e9824513c570370638b1bfe33bf1dba1f12be4a.tar
patches-1e9824513c570370638b1bfe33bf1dba1f12be4a.tar.gz
Merge branch 'nix-integration'
Conflicts: tests/guix-package.sh
Diffstat (limited to 'release.nix')
-rw-r--r--release.nix35
1 files changed, 24 insertions, 11 deletions
diff --git a/release.nix b/release.nix
index 1b913b497b..2d3a70f524 100644
--- a/release.nix
+++ b/release.nix
@@ -48,11 +48,12 @@ let
pkgs.releaseTools.sourceTarball {
name = "guix-tarball";
src = <guix>;
- buildInputs = with pkgs; [ guile ];
+ buildInputs = with pkgs; [ guile sqlite bzip2 git libgcrypt ];
buildNativeInputs = with pkgs; [ texinfo gettext cvs pkgconfig ];
+ preAutoconf = ''git config submodule.gnulib.url "${<gnulib>}"'';
configureFlags =
- [ "--with-nix-prefix=${pkgs.nix}"
- "--with-libgcrypt-prefix=${pkgs.libgcrypt}"
+ [ "--with-libgcrypt-prefix=${pkgs.libgcrypt}"
+ "--localstatedir=/nix/var/nix"
];
};
@@ -62,12 +63,12 @@ let
let pkgs = import nixpkgs { inherit system; }; in
pkgs.releaseTools.nixBuild {
name = "guix";
- buildInputs = [ pkgs.guile ];
+ buildInputs = with pkgs; [ guile sqlite bzip2 libgcrypt ];
buildNativeInputs = [ pkgs.pkgconfig ];
src = jobs.tarball;
configureFlags =
- [ "--with-nix-prefix=${pkgs.nix}"
- "--with-libgcrypt-prefix=${pkgs.libgcrypt}"
+ [ "--with-libgcrypt-prefix=${pkgs.libgcrypt}"
+ "--localstatedir=/nix/var/nix"
];
preBuild =
@@ -80,16 +81,28 @@ let
distro/packages/bootstrap/x86_64-linux/guile-bootstrap-2.0.6.tar.xz
'';
- # XXX: Since we need to talk to a running daemon, for the benefit of
- # `nixpkgs-derivation*' & co., we need to escape the chroot.
- preConfigure = "export NIX_REMOTE=daemon";
- __noChroot = true;
-
inherit succeedOnFailure keepBuildDirectory
buildOutOfSourceTree;
};
+ build_disable_daemon =
+ { system ? builtins.currentSystem }:
+
+ let
+ pkgs = import nixpkgs { inherit system; };
+ build = jobs.build { inherit system; };
+ in
+ pkgs.lib.overrideDerivation build ({ configureFlags, ... }: {
+ configureFlags = configureFlags ++ [ "--disable-daemon" ];
+ buildInputs = with pkgs; [ guile nixUnstable pkgconfig ];
+
+ # Since we need to talk to a running daemon, we need to escape
+ # the chroot.
+ preConfigure = "export NIX_REMOTE=daemon";
+ __noChroot = true;
+ });
+
# Jobs to test the distro.
distro = {
hello =