summaryrefslogtreecommitdiff
path: root/po
diff options
context:
space:
mode:
authorChristopher Baines <mail@cbaines.net>2019-07-02 20:25:41 +0100
committerChristopher Baines <mail@cbaines.net>2019-07-15 22:32:19 +0100
commitf363c836e0b4c416dae594af4257459da592b35c (patch)
tree8609adde0b79d7161323d166ad252ceff83dcfea /po
parent57238532f44f99d4770508ba11e105299c96590b (diff)
downloadpatches-f363c836e0b4c416dae594af4257459da592b35c.tar
patches-f363c836e0b4c416dae594af4257459da592b35c.tar.gz
lint: Move the linting code to a different module.
To try and move towards making programatic access to the linting code easier, this commit separates out the linting script, from the linting functionality that it uses. * guix/scripts/lint.scm (emit-warnings): Alter to to not use match-lambda, as <lint-warning> isn't accessible. (<lint-warning>, lint-warning, make-lint-warning, lint-warning?, lint-warning-message, lint-warning-message-text, lint-warning-message-data, lint-warning-location, package-file, %make-warning make-warning, <lint-checker>, lint-checker, make-lint-checker, lint-checker?, lint-checker-name, lint-checker-description, lint-checker-check, properly-starts-sentance?, starts-with-abbreviation?, %quoted-identifier-rx, check-description-style, package-input-intersection, check-inputs-should-be-native, check-inputs-should-not-be-an-input-at-all, package-name-regexp, check-synopsis-style, probe-uri, tls-certificate-error-string, validate-uri, check-home-page, %distro-directory, check-patch-file-names, escape-quotes, official-gnu-packages*, check-gnu-synopsis+description, origin-uris, check-source, check-source-file-name, check-source-unstable-tarball, check-mirror-url, check-github-url, check-derivation, check-license, call-with-networking-fail-safe, with-networking-fail-safe, current-vulnerabilities*, package-vulnerabilities, check-vulnerabilities, check-for-updates, report-tabulations, report-trailing-white-space, report-long-line, %hanging-paren-rx, report-lone-parantheses, %formatting-reporters, report-formatting-issues, check-formatting, %checkers): Move to… * guix/lint.scm: … here * po/guix/POTFILES.in: Add guix/lint.scm. * Makefile.am: Add guix/lint.scm. * tests/lint.scm: Change to import (guix lint), rather than (guix scripts lint).
Diffstat (limited to 'po')
-rw-r--r--po/guix/POTFILES.in1
1 files changed, 1 insertions, 0 deletions
diff --git a/po/guix/POTFILES.in b/po/guix/POTFILES.in
index ad06ebce95..8b556ac0ec 100644
--- a/po/guix/POTFILES.in
+++ b/po/guix/POTFILES.in
@@ -40,6 +40,7 @@ gnu/machine/ssh.scm
guix/scripts.scm
guix/scripts/build.scm
guix/discovery.scm
+guix/lint.scm
guix/scripts/download.scm
guix/scripts/package.scm
guix/scripts/install.scm