summaryrefslogtreecommitdiff
path: root/nix
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2019-09-03 21:59:45 +0200
committerLudovic Courtès <ludo@gnu.org>2019-09-08 11:49:24 +0200
commit9fcc35c51fd579b3bb7b4f61cba6973675c3922c (patch)
tree51dcf3d81a20f2cc3330d329ccf4f8537d203578 /nix
parent0c684b7edfacada4f576855dbb09291f04a84fa2 (diff)
downloadpatches-9fcc35c51fd579b3bb7b4f61cba6973675c3922c.tar
patches-9fcc35c51fd579b3bb7b4f61cba6973675c3922c.tar.gz
daemon: Run 'guix perform-download' directly.
* nix/scripts/download.in: Remove. * nix/local.mk (nodist_pkglibexec_SCRIPTS): Remove 'scripts/download'. * config-daemon.ac: Don't output 'nix/scripts/download'. * nix/libstore/builtins.cc (builtinDownload): Invoke 'guix perform-download' directly.
Diffstat (limited to 'nix')
-rw-r--r--nix/libstore/builtins.cc4
-rw-r--r--nix/local.mk3
-rw-r--r--nix/scripts/download.in11
3 files changed, 3 insertions, 15 deletions
diff --git a/nix/libstore/builtins.cc b/nix/libstore/builtins.cc
index f7c7d42484..4111ac4760 100644
--- a/nix/libstore/builtins.cc
+++ b/nix/libstore/builtins.cc
@@ -39,7 +39,7 @@ static void builtinDownload(const Derivation &drv,
const char *const argv[] =
{
- "download", drvPath.c_str(), output.c_str(), NULL
+ "guix", "perform-download", drvPath.c_str(), output.c_str(), NULL
};
/* Tell the script what the store file name is, so that
@@ -50,7 +50,7 @@ static void builtinDownload(const Derivation &drv,
/* Tell it about options such as "print-extended-build-trace". */
setenv("_NIX_OPTIONS", settings.pack().c_str(), 1);
- const string program = settings.nixLibexecDir + "/download";
+ const string program = settings.guixProgram;
execv(program.c_str(), (char *const *) argv);
throw SysError(format("failed to run download program '%1%'") % program);
diff --git a/nix/local.mk b/nix/local.mk
index cdcd9eb1c2..c4c3920fa3 100644
--- a/nix/local.mk
+++ b/nix/local.mk
@@ -155,8 +155,7 @@ noinst_HEADERS = \
(write (get-string-all in) out)))))"
nodist_pkglibexec_SCRIPTS = \
- %D%/scripts/substitute \
- %D%/scripts/download
+ %D%/scripts/substitute
if BUILD_DAEMON_OFFLOAD
diff --git a/nix/scripts/download.in b/nix/scripts/download.in
deleted file mode 100644
index 4d7088a993..0000000000
--- a/nix/scripts/download.in
+++ /dev/null
@@ -1,11 +0,0 @@
-#!@SHELL@
-# A shorthand for "guix perform-download", for use by the daemon.
-
-if test "x$GUIX_UNINSTALLED" = "x"
-then
- prefix="@prefix@"
- exec_prefix="@exec_prefix@"
- exec "@bindir@/guix" perform-download "$@"
-else
- exec guix perform-download "$@"
-fi