summaryrefslogtreecommitdiff
path: root/nix
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2019-09-04 12:00:31 +0200
committerLudovic Courtès <ludo@gnu.org>2019-09-08 11:49:24 +0200
commit82f903e70f580c34503052245625354d2f097d7e (patch)
treebffe5f2fdadc679ed930023886ac8b4e658df70d /nix
parentf6919ebdc6b0ce0286814cc6ab0564b1a4c67f5f (diff)
downloadpatches-82f903e70f580c34503052245625354d2f097d7e.tar
patches-82f903e70f580c34503052245625354d2f097d7e.tar.gz
daemon: Remove 'NIX_LIBEXEC_DIR'.
* nix/libstore/globals.hh (Settings)[nixLibexecDir]: Remove. * nix/libstore/globals.cc (Settings::processEnvironment): Remove reference to 'nixLibexecDir'. * nix/local.mk (libstore_a_CPPFLAGS): Remove -DNIX_LIBEXEC_DIR flag. * build-aux/pre-inst-env.in: Remove references to 'NIX_LIBEXEC_DIR'.
Diffstat (limited to 'nix')
-rw-r--r--nix/libstore/globals.cc1
-rw-r--r--nix/libstore/globals.hh3
-rw-r--r--nix/local.mk1
3 files changed, 0 insertions, 5 deletions
diff --git a/nix/libstore/globals.cc b/nix/libstore/globals.cc
index 8f7c976fcb..0cc001fbe4 100644
--- a/nix/libstore/globals.cc
+++ b/nix/libstore/globals.cc
@@ -70,7 +70,6 @@ void Settings::processEnvironment()
nixStateDir = canonPath(getEnv("GUIX_STATE_DIRECTORY", NIX_STATE_DIR));
nixDBPath = getEnv("GUIX_DATABASE_DIRECTORY", nixStateDir + "/db");
nixConfDir = canonPath(getEnv("GUIX_CONFIGURATION_DIRECTORY", GUIX_CONFIGURATION_DIRECTORY));
- nixLibexecDir = canonPath(getEnv("NIX_LIBEXEC_DIR", NIX_LIBEXEC_DIR));
nixBinDir = canonPath(getEnv("NIX_BIN_DIR", NIX_BIN_DIR));
nixDaemonSocketFile = canonPath(nixStateDir + DEFAULT_SOCKET_PATH);
guixProgram = canonPath(getEnv("GUIX", nixBinDir + "/guix"));
diff --git a/nix/libstore/globals.hh b/nix/libstore/globals.hh
index 0069c85956..27616a2283 100644
--- a/nix/libstore/globals.hh
+++ b/nix/libstore/globals.hh
@@ -57,9 +57,6 @@ struct Settings {
/* The directory where configuration files are stored. */
Path nixConfDir;
- /* The directory where internal helper programs are stored. */
- Path nixLibexecDir;
-
/* The directory where the main programs are stored. */
Path nixBinDir;
diff --git a/nix/local.mk b/nix/local.mk
index 18e9ba7604..dc5a8398b2 100644
--- a/nix/local.mk
+++ b/nix/local.mk
@@ -110,7 +110,6 @@ libstore_a_CPPFLAGS = \
-DNIX_STATE_DIR=\"$(localstatedir)/guix\" \
-DNIX_LOG_DIR=\"$(localstatedir)/log/guix\" \
-DGUIX_CONFIGURATION_DIRECTORY=\"$(sysconfdir)/guix\" \
- -DNIX_LIBEXEC_DIR=\"$(libexecdir)/guix\" \
-DNIX_BIN_DIR=\"$(bindir)\" \
-DDEFAULT_CHROOT_DIRS="\"\""