summaryrefslogtreecommitdiff
path: root/nix
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2016-05-31 14:37:54 +0200
committerLudovic Courtès <ludo@gnu.org>2016-05-31 18:22:14 +0200
commit75abbd0cbe2c42f07fa104f97bd206891eb576ef (patch)
tree00b142a62feffa35baca05fac896e14f10e7fc46 /nix
parent23aab4ab2cb8464b3c7907c8a164fd5710a24e0e (diff)
downloadpatches-75abbd0cbe2c42f07fa104f97bd206891eb576ef.tar
patches-75abbd0cbe2c42f07fa104f97bd206891eb576ef.tar.gz
daemon: Remove unused XML output code.
* nix/local.mk (libutil_a_SOURCES): Remove libutil/xml-writer.cc. (libutil_headers): Remove libutil/xml-writer.hh. * nix/libutil/xml-writer.hh, nix/libutil/xml-writer.cc: Remove.
Diffstat (limited to 'nix')
-rw-r--r--nix/libutil/xml-writer.cc94
-rw-r--r--nix/libutil/xml-writer.hh69
-rw-r--r--nix/local.mk2
3 files changed, 0 insertions, 165 deletions
diff --git a/nix/libutil/xml-writer.cc b/nix/libutil/xml-writer.cc
deleted file mode 100644
index 01794001b2..0000000000
--- a/nix/libutil/xml-writer.cc
+++ /dev/null
@@ -1,94 +0,0 @@
-#include <assert.h>
-
-#include "xml-writer.hh"
-
-
-namespace nix {
-
-
-XMLWriter::XMLWriter(bool indent, std::ostream & output)
- : output(output), indent(indent)
-{
- output << "<?xml version='1.0' encoding='utf-8'?>" << std::endl;
- closed = false;
-}
-
-
-XMLWriter::~XMLWriter()
-{
- close();
-}
-
-
-void XMLWriter::close()
-{
- if (closed) return;
- while (!pendingElems.empty()) closeElement();
- closed = true;
-}
-
-
-void XMLWriter::indent_(unsigned int depth)
-{
- if (!indent) return;
- output << string(depth * 2, ' ');
-}
-
-
-void XMLWriter::openElement(const string & name,
- const XMLAttrs & attrs)
-{
- assert(!closed);
- indent_(pendingElems.size());
- output << "<" << name;
- writeAttrs(attrs);
- output << ">";
- if (indent) output << std::endl;
- pendingElems.push_back(name);
-}
-
-
-void XMLWriter::closeElement()
-{
- assert(!pendingElems.empty());
- indent_(pendingElems.size() - 1);
- output << "</" << pendingElems.back() << ">";
- if (indent) output << std::endl;
- pendingElems.pop_back();
- if (pendingElems.empty()) closed = true;
-}
-
-
-void XMLWriter::writeEmptyElement(const string & name,
- const XMLAttrs & attrs)
-{
- assert(!closed);
- indent_(pendingElems.size());
- output << "<" << name;
- writeAttrs(attrs);
- output << " />";
- if (indent) output << std::endl;
-}
-
-
-void XMLWriter::writeAttrs(const XMLAttrs & attrs)
-{
- for (XMLAttrs::const_iterator i = attrs.begin(); i != attrs.end(); ++i) {
- output << " " << i->first << "=\"";
- for (unsigned int j = 0; j < i->second.size(); ++j) {
- char c = i->second[j];
- if (c == '"') output << "&quot;";
- else if (c == '<') output << "&lt;";
- else if (c == '>') output << "&gt;";
- else if (c == '&') output << "&amp;";
- /* Escape newlines to prevent attribute normalisation (see
- XML spec, section 3.3.3. */
- else if (c == '\n') output << "&#xA;";
- else output << c;
- }
- output << "\"";
- }
-}
-
-
-}
diff --git a/nix/libutil/xml-writer.hh b/nix/libutil/xml-writer.hh
deleted file mode 100644
index 3cefe3712c..0000000000
--- a/nix/libutil/xml-writer.hh
+++ /dev/null
@@ -1,69 +0,0 @@
-#pragma once
-
-#include <iostream>
-#include <string>
-#include <list>
-#include <map>
-
-
-namespace nix {
-
-using std::string;
-using std::map;
-using std::list;
-
-
-typedef map<string, string> XMLAttrs;
-
-
-class XMLWriter
-{
-private:
-
- std::ostream & output;
-
- bool indent;
- bool closed;
-
- list<string> pendingElems;
-
-public:
-
- XMLWriter(bool indent, std::ostream & output);
- ~XMLWriter();
-
- void close();
-
- void openElement(const string & name,
- const XMLAttrs & attrs = XMLAttrs());
- void closeElement();
-
- void writeEmptyElement(const string & name,
- const XMLAttrs & attrs = XMLAttrs());
-
-private:
- void writeAttrs(const XMLAttrs & attrs);
-
- void indent_(unsigned int depth);
-};
-
-
-class XMLOpenElement
-{
-private:
- XMLWriter & writer;
-public:
- XMLOpenElement(XMLWriter & writer, const string & name,
- const XMLAttrs & attrs = XMLAttrs())
- : writer(writer)
- {
- writer.openElement(name, attrs);
- }
- ~XMLOpenElement()
- {
- writer.closeElement();
- }
-};
-
-
-}
diff --git a/nix/local.mk b/nix/local.mk
index be57894eaf..07a92f74ea 100644
--- a/nix/local.mk
+++ b/nix/local.mk
@@ -55,7 +55,6 @@ libutil_a_SOURCES = \
%D%/libutil/affinity.cc \
%D%/libutil/serialise.cc \
%D%/libutil/util.cc \
- %D%/libutil/xml-writer.cc \
%D%/libutil/hash.cc \
%D%/libutil/gcrypt-hash.cc
@@ -63,7 +62,6 @@ libutil_headers = \
%D%/libutil/affinity.hh \
%D%/libutil/hash.hh \
%D%/libutil/serialise.hh \
- %D%/libutil/xml-writer.hh \
%D%/libutil/util.hh \
%D%/libutil/archive.hh \
%D%/libutil/types.hh \